Downgrading and 7.6

Discussion in 'iPod touch 1.1.x Jailbreak' started by SiLEnt_09, Jan 17, 2008.

  1. SiLEnt_09

    SiLEnt_09 New Member

    Nov 29, 2007
    Likes Received:
    Hey all,
    I have a new ipod touch, version 1.1.2. and im trying to downgrade it to 1.1.1 to jailbreak it. I recently downloaded itunes version 7.6 and I have a few questions. I downloaded the file from [] etc, but when i right click restore and pick the 1.1.1 file, it always comes up saying error. Is it because i have version 7.6 of itunes? Is there a way to get around it without uninstalling Itunes, and downloading 7.5?
    Thanks in advance guys

    EDIT: Is it necessary to downgrade before i jailbreak? Im assuming i cant just jailbreak 1.1.2 straight up, but wouldnt hurt to ask

Share This Page