Downgrade to 3.1.2 Error 28

Discussion in 'iPod touch' started by Luigirez1, Jul 14, 2010.

  1. Luigirez1

    Luigirez1 New Member

    Joined:
    Jun 3, 2010
    Messages:
    36
    Likes Received:
    0
    Device:
    4G iPod touch
    i am trying to downgrade to 3.1.2 and when i try to do it i get error 28. I have ios 4 ipod touch 2nd gen MC with itunes 9.0.3.
    Any help?
    ------------------double post merged------------------
    oh i give up...

Share This Page