Do you need the lastest iTunes and iPhone software for developing

Discussion in 'iOS Development' started by kidlazer, Oct 3, 2010.

  1. kidlazer

    kidlazer New Member

    Joined:
    Oct 7, 2008
    Messages:
    37
    Likes Received:
    0
    My iPhone is jailbroken at 3.1.3 and since i'm having trouble upgrading to at LEAST 4.0.1, for now i'm staying at 3.1.3.

    Do i need to have the lastest iTunes 10 and iOS 4.1 to start developing or is it okay for me to pay the $99 and go ahead with my iTunes 9.2 and current fw?
  2. Freerunnering

    Freerunnering Member

    Joined:
    Sep 1, 2009
    Messages:
    296
    Likes Received:
    0
    Device:
    4G iPod touch
    As long as the SDK is upto date and the iOS version isn't too old to use with it, i don't think it makes a difference what your devices firmware is?
    Though some iOS versions (3.0 for example) are too old to use with the latest SDK and i don't know what the cut off is?
  3. link07

    link07 Active Member

    Joined:
    Jun 15, 2010
    Messages:
    1,612
    Likes Received:
    3
    Device:
    4G iPod touch
  4. kidlazer

    kidlazer New Member

    Joined:
    Oct 7, 2008
    Messages:
    37
    Likes Received:
    0
    thats cool. just wondering.

    I don't want to pay $99 and then realize i can't use it.

Share This Page