do you need 2.0 to play games?

Discussion in 'iTunes App Store Games & Apps' started by devdagod, Jul 11, 2008.

  1. devdagod

    devdagod New Member

    Joined:
    Dec 26, 2007
    Messages:
    9
    Likes Received:
    0
    Device:
    iPod touch
    so do you need firmware 2.0 to play app store games? thanks
  2. pistolpeet

    pistolpeet New Member

    Joined:
    Jun 2, 2008
    Messages:
    37
    Likes Received:
    0
    yes, if u would read even apple site, it seys with * app store requires 2.0
  3. devdagod

    devdagod New Member

    Joined:
    Dec 26, 2007
    Messages:
    9
    Likes Received:
    0
    Device:
    iPod touch
    oh well im not gonna upgrade till 2.0 is hackable then, thanks
  4. 1adam1

    1adam1 Member

    Joined:
    Mar 8, 2008
    Messages:
    490
    Likes Received:
    0
    Device:
    4G iPod touch
    you bring a new meaning to the term "noob"
  5. Joe Rossignol

    Joe Rossignol Community Manager Staff Member

    Joined:
    Jan 9, 2008
    Messages:
    11,500
    Likes Received:
    1,268
    Device:
    iPhone 5 (Black)
    Don't criticize him because you think you're a "know-it-all" and they should automatically know all this information of the top of their heads. If you're not going to contribute, don't post. Anyways, you'll need Firmware 2.0 to run the applications from App Store, which is free for iPhone users and $9.99 for iPod touch users (at the time of this post, Firmware 2.0 is currently unreleased for the iPod touch.)
  6. spoonforknife

    spoonforknife Retired Moderator

    Joined:
    Nov 15, 2007
    Messages:
    6,896
    Likes Received:
    317
    I find it interesting that you do not answer the question.

    The answer is no.
    Games can be played with jailbroken iPod touches, but not stock pre-2.0 firmwares.

Share This Page