do you need 1.13 to rent movies?

Discussion in 'iPod touch Firmware 1.1.3 Discussions' started by btothe3, Jan 21, 2008.

  1. btothe3

    btothe3 Banned

    Joined:
    Jan 21, 2008
    Messages:
    48
    Likes Received:
    3
    Need to know for vacation
  2. Charlie Chambers

    Charlie Chambers New Member

    Joined:
    Oct 11, 2007
    Messages:
    36
    Likes Received:
    1
    Yes, you need 1.1.3. However, you don't have to buy the $20 update.
  3. btothe3

    btothe3 Banned

    Joined:
    Jan 21, 2008
    Messages:
    48
    Likes Received:
    3
    thank you man

Share This Page