Do we need 2.1.1 installed?

Discussion in 'iPod touch 2G Jailbreak: redsn0w, 24kpwn, etc.' started by arberb, Jan 31, 2009.

  1. arberb

    arberb New Member

    Joined:
    Jan 25, 2009
    Messages:
    66
    Likes Received:
    0

Share This Page