Do we need 1.1.3 and 64bit

Discussion in 'iPod touch Firmware 1.1.3 Discussions' started by dualcorex, Jan 15, 2008.

  1. dualcorex

    dualcorex New Member

    Joined:
    Sep 16, 2007
    Messages:
    1,487
    Likes Received:
    36
    Do we need to have the 1.1.3 on the touch to use it with a 64 bit vista machine? anyone know. or is it just itunes that makes the difference?

Share This Page