Do I really HAVE to update to 3.0 ?

Discussion in 'iPod touch Firmware 3.0' started by deleted account, Sep 7, 2009.

  1. Well the past few days, I updated my iPod Touch 2g 2.2.1 to 3.0, and then jailbroke it. Long story short, I decided to go back and downgraded to 2.2.1 and everything seemed to work but I remembered that some apps wouldn't upgrade because I didn't have version 3.0.

    SO, after syncing my apps, MySpace, Facebook, OneTap, and a few others wont sync to my iPod anymore because they require 3.0, and before I tried upgrading, I just kept the older versions because they still worked.

    My question is, is there any way to download earlier versions of apps that aren't necessarily for 3.0 ? I know you can add apps through SSH, but can you do the same with free apps usually taken from the App Store? Or do I really HAVE to upgrade now to get them to work ?

    And sorry if this isn't the right place to ask this, I wasn't quite sure where this fit in

    Please Register or Log in to view images

  2. ipodfan256

    ipodfan256 New Member

    Joined:
    Apr 7, 2009
    Messages:
    218
    Likes Received:
    0
    Device:
    iPod touch
    Just upgrade it not that hard

    Then just redownload your app or sync though iTunes
  3. deadlyvirus

    deadlyvirus New Member

    Joined:
    Jan 2, 2008
    Messages:
    2,157
    Likes Received:
    0
    Device:
    4G iPod touch
    Support for 2.2.1 is going to drop out soon. You really are better off upgrading.
  4. I went back from 3.0 because after shutting it off, no matter what I did, it wouldn't start up again. It'd just show the logo and the little spinning wheel would go on for a few minutes, then it'd shut off, start up and do the same. I'd have to restore it, but it'd do the same. So if you can answer as to why it won't start properly to be able to do anything, then I'd rather have use of my iPod with outdated apps than upgrade and no be able to use anything.

    And thank you deadlyvirus for a calm and respectful reply.
  5. deadlyvirus

    deadlyvirus New Member

    Joined:
    Jan 2, 2008
    Messages:
    2,157
    Likes Received:
    0
    Device:
    4G iPod touch
    That's ummmm odd to say the least. 3.1 should be rolling around soon. Maybe that one will work? Also, when you try to boot 3.0, is this after you have set it up as a backup of a previous installation?
  6. Ah, 8th time's the charm I suppose. Tricky little bugger, apparently Winterboard caused the same effect. Just tried my luck again and so far it seems to be working. Even shut it off and booted up with no problem. Hopefully it'll last.

    Sorry for the pointless thread now, maybe the Mods can delete it ? haha. Thanks for those who took interest in my question.

Share This Page