Do I need itunes 7.6 ti downgrade?

Discussion in 'iPod touch' started by T0uchD0wn, Jan 31, 2008.

  1. T0uchD0wn

    T0uchD0wn New Member

    Joined:
    Jan 28, 2008
    Messages:
    33
    Likes Received:
    0
    From 1.1.3 to 1.1.1? I've tried many times with iphuc on 6, do I need 7?

    Please Register or Log in to view images

  2. plg6067

    plg6067 New Member

    Joined:
    Sep 22, 2007
    Messages:
    835
    Likes Received:
    2
  3. T0uchD0wn

    T0uchD0wn New Member

    Joined:
    Jan 28, 2008
    Messages:
    33
    Likes Received:
    0
  4. yankeeland

    yankeeland New Member

    Joined:
    Nov 27, 2007
    Messages:
    57
    Likes Received:
    0
    I upgraded my niece's Touch with Itunes 7.4.2.4 for 1.1.3 fw.

Share This Page