do all apps now work with 3.0 firmware?

Discussion in 'iPod touch Firmware 3.0' started by tuner32, Aug 4, 2009.

  1. tuner32

    tuner32 New Member

    Joined:
    Sep 9, 2008
    Messages:
    12
    Likes Received:
    0
    Device:
    2G iPod touch
    Do all apps now work with 3.0 firmware? I have an ipod touch 2nd gen and don't want to pay £6 to upgrade if it means that some of my apps wont work.
  2. timidestemu

    timidestemu New Member

    Joined:
    Mar 31, 2009
    Messages:
    15
    Likes Received:
    0
    im pretty sure all the app store apps work but i know for a fact that some of the cydia apps do not.
  3. ben

    ben Banned

    Joined:
    Nov 27, 2008
    Messages:
    734
    Likes Received:
    0
    Device:
    2G iPod touch
    All app store apps work.
    If the Dev hasn't been working on the app for awhile, it might be slightly buggy.
    If you're planning to jailbreak it, then yes, there are a few Cydia apps that are incompatible with 3.0. Heres a list of the working/non-working Cydia apps.
  4. touch_iPod

    touch_iPod Well-Known Member

    Joined:
    Mar 11, 2009
    Messages:
    3,023
    Likes Received:
    144
    Device:
    iPhone 5 (White)
    All apps in the App Store certainly can work with the 3.0 firmware... Even developers of older apps will mention in their update details that the app is "OS 3.0 Compliant"...

Share This Page