Discussion in 'iPod touch' started by deleted account, Apr 3, 2010.

  1. (FIXED)"Waiting for Ipod" Message while restoring


    I did something to my iPod touch 2G 3.1.2 jailbroken and it kept rebooting all the time!

    I did something else so it showed that I had to connect my ipod to itunes so i could restore it.

    After I clicked "restore" the screen on ipod went white for a nanosecond and kinda rebooted. (i don't know if that's normal)
    While restoring it eventually stays on the "waiting for ipod" message.. and on the ipod screen there's a apple logo with a empty bar.
    http://i43.tinypic.com/343t8j7.png < The message on PC

    I tried downloading firmwares and shift + click on restore, but no success..

    I also tried DFU mode, the screen stays white for a few seconds and then the apple logo comes and later the empty bar. but also with dfu mode it keeps showing "waiting for ipod".

    I really don't have a clue what to do, it really seems something doesn't work internally in my Ipod.
    I could take it to Apple but I'd really like to fix it myself, because my iPod is jailbroken.
    If nothing helps I'll go to Apple

    If anyone had this problem or knows what to do, please help me out

    Please Register or Log in to view images

    P.S: I checked other similar topics and they weren't very useful to me.

    I got it working now !!!!!! I restored it to 2.2.1 with help of a program called iReb (a program which helps u downgrade)
  2. bboytopher

    bboytopher New Member

    Apr 2, 2010
    Likes Received:
    iPod touch
    i have the same problem it connect to itunes and says its in dfu mode then i try the official restore and it gives me error 1600 an when i try shift+restore it does the same thing i just tried restoring my ipod touch with 2.0.2 firmware but its sitting at the apple logo with no progress bar an there never showed one
  3. Appman

    Appman Community Development Staff Member

    Jul 9, 2009
    Likes Received:
    4G iPod touch
    Hmm...what version of iTunes do you have?
  4. Unregistered

    Unregistered Guest

    What did you do to fix the "Waiting for iPod" issue with iReb exactly? Coz I`ve been trying to do it and I can`t seem to make it budge (n)

Share This Page