Cydia problems after update..

Discussion in 'iPod touch Firmware 3.0' started by Camoka, Jul 19, 2009.

  1. Camoka

    Camoka New Member

    Joined:
    Aug 18, 2008
    Messages:
    14
    Likes Received:
    0
    Device:
    iPod touch
    Hello Guys

    I was away for long time after update 2.2 which I was pretty happy about it..After all the fuss about 3.0 ,I wanted to upgrade my ipod by using pwnage tool..I successfully did it..After update cydia started to keep crashing..also sometime I am not able to see the contents of the things that i want to download.Cydia version in my ipod is v 1.0.2953-59..How can I upgrade my cydia to latest version?I looked around in cydia and didnt see any new version to download

    Please Register or Log in to view images

  2. Universal Denizen

    Universal Denizen Member

    Joined:
    Mar 23, 2009
    Messages:
    768
    Likes Received:
    0
    Device:
    2G iPod touch
  3. Ronald Coleman

    Ronald Coleman New Member

    Joined:
    Jul 14, 2009
    Messages:
    34
    Likes Received:
    0
    Device:
    2G iPod touch
    it asks me if i want to upgrade, so i did...

    Now cydia won't even load
  4. Camoka

    Camoka New Member

    Joined:
    Aug 18, 2008
    Messages:
    14
    Likes Received:
    0
    Device:
    iPod touch
    Mine is working ok if I compare to other people..Only problem is cydia which is crashing very often and loosing wifi connection time to time..I was able to download stuff..I will keep using like this until they find some fixes..I think since 3.0 is very new people are still working on it.If they release a working version of cydia most of the problems should be covered..
  5. Ronald Coleman

    Ronald Coleman New Member

    Joined:
    Jul 14, 2009
    Messages:
    34
    Likes Received:
    0
    Device:
    2G iPod touch
    When i open cydia it says there are essential upgrades, i have the option to upgrade the essentials, complete upgrade, and ignore temp.

    When i pick the first option it gives me an error (so does the second option) then when i ignore i can search for apps and packages, but when i install them, i get another error saying i need the essential upgrades...

    Any help please????

    EDIT:
    I fixed this by re installing cydia only

Share This Page