Connected to wifi, Internet works, but no wifi icon

Discussion in 'iPod touch' started by queerasmoi, Sep 22, 2009.

  1. queerasmoi

    queerasmoi New Member

    Joined:
    Sep 13, 2009
    Messages:
    5
    Likes Received:
    0
    Device:
    2G iPod touch
    I can't seem to find any references to this problem. A while back I was at a library with a strange internet connection, and subsequently I started having a strange problem: The wifi would connect but there would be no wifi icon beside "iPod" in the title bar. The Internet would still work but it just never tells me visually.

    I fixed it with a backup and restore. (Yay!).

    Fastforward to tonight. I was having problems with the Facebook app and kept trying to force quit it a few times until it'd work. And then out of the blue my wifi icon dropped. Again the net works but no confirmatory icon. So I endured another full backup-restore cycle, and my restored iPod... STILL has no wifi icon when connected. Booooo.

    Anyone had this problem before?
  2. superrob

    superrob Member

    Joined:
    Dec 9, 2008
    Messages:
    580
    Likes Received:
    1
    Device:
    iPhone 4S (Black)
    Sounds wierd.. never experienced anything like this. Is it ONLY in the libary or even at home now?
  3. queerasmoi

    queerasmoi New Member

    Joined:
    Sep 13, 2009
    Messages:
    5
    Likes Received:
    0
    Device:
    2G iPod touch
    Anywhere - home, library, school. It's annoying because some locations have flaky connections and, without the wifi icon, it's hard to tell which type of connection problem I'm having.
  4. queerasmoi

    queerasmoi New Member

    Joined:
    Sep 13, 2009
    Messages:
    5
    Likes Received:
    0
    Device:
    2G iPod touch
    Okay, well, resetting my network settings did it. Now I've lost a bunch of people's wifi passwords but at least the bug is gone.
  5. Stevvie

    Stevvie Member

    Joined:
    Aug 6, 2009
    Messages:
    76
    Likes Received:
    0
    Device:
    3G iPod touch
    How do you reset your network settings as I'm getting the SAME problem here. I've deleted my settings for my network router in ipods settings and then imput them again but still the same thing.
  6. Chamilism

    Chamilism New Member

    Joined:
    Dec 27, 2009
    Messages:
    637
    Likes Received:
    0
    Device:
    iPhone 4 (White)
    Exactly.

    and go on your computer for a couple mins to get the router starting to go.
  7. jims99

    jims99 New Member

    Joined:
    Feb 14, 2010
    Messages:
    2
    Likes Received:
    0
    Device:
    2G iPod touch
    Having same problem - losing wifi icon

    Hi q,
    I also keep losing my wifi icon and also the reload icon (rotating wheel). I've had to do hard resets to fix, but it keeps happening. A week ago I updated to 3.1.3, and immediately lost the icons. Apple store techies are of no help what problem is. HAve you new info what may cause this?
    Any help appreciated.
    Jim
  8. Stevvie

    Stevvie Member

    Joined:
    Aug 6, 2009
    Messages:
    76
    Likes Received:
    0
    Device:
    3G iPod touch
    No new info but I had to do a restore to fix it. Seems like a bug for a few people that has been there on all OS's. Apple tech were VERY fast to respond but said it's the first time he's heard of this problem. I redirected him to the MANY post on the forums found by doing a simple google search.
  9. hayntaptap

    hayntaptap New Member

    Joined:
    Nov 24, 2009
    Messages:
    98
    Likes Received:
    0
    Device:
    2G iPod touch
    I have no idea, but this HAS happened to me before couple times

    but it just fixed on it's own when i connected to another wifi spot
    idk how exactly to solve it

    Please Register or Log in to view images



    sorry
  10. Danielcg

    Danielcg Banned

    Joined:
    May 18, 2010
    Messages:
    83
    Likes Received:
    0
    Device:
    3G iPod touch
    I accidentally deleted mine with iFile (stupid mistake) i forgot to back them up and i was putting my own icons in because i couldent find a winterboard theme with the icon i wanted

Share This Page