Confusing jailbreak

Discussion in 'iOS Jailbreak & Cydia' started by Bobnik, Jul 8, 2010.

  1. Bobnik

    Bobnik New Member

    Joined:
    Jul 8, 2010
    Messages:
    2
    Likes Received:
    0
    THIS HAS NOT BEEN SOLVED AS OF YET.

    Feel free to move this if it doesn't belong here. It's the best forum match I could find.

    My friend asked me to Jailbreak his Ipod touch, (2nd Generation, MC model, 3.1.3) and I've been trying to figure something out for the last few hours. His Ipod has been running a bit slow as of late, so I had planned on doing a restore before I jailbroke it. The problem was, Itunes kept telling me that "the Ipod is not eligible for the requested build" or something like that. Apparently, Apple doesn't support the software (3.1.3) anymore or something. Around here, I started reading things that mentioned "blob files". I have no idea what they are, and I'm a bit nervous to proceed until I figure them out.

    My original plan was to upgrade to 4.0, and then downgrade to 3.1.2, but I'm not so sure what to do anymore. Any help would be appreciated!

    EDIT: As I mention in a later post, the Ipod is STILL running 3.1.3; It was not upgraded to 4.0, nor has it ever been.
  2. Mookler

    Mookler Banned

    Joined:
    Sep 16, 2007
    Messages:
    1,251
    Likes Received:
    2
    Device:
    iPhone 4S (Black)
    They no longer authorize older firmwares, you have to have your ECID saved, which I assume you dont. As so, youre stuck with 4.0
  3. Bobnik

    Bobnik New Member

    Joined:
    Jul 8, 2010
    Messages:
    2
    Likes Received:
    0
    I didn't upgrade to 4.0 yet.

    I stopped just before hitting the "Upgrade" button to come and post this.
  4. Shengis14

    Shengis14 Member

    Joined:
    Apr 15, 2010
    Messages:
    394
    Likes Received:
    0
    Device:
    iPad 3
    the ipod touch 2g MC-model dosnt need SHSH blobs, just google "ipod touch 2g 3.1.3 firmware", download it and then, on itunes, HOLD SHIFT + CLICK on restore and select the firmware you just downloaded.

    then use spirit to jailbreak

    you may get an error while restoring, for example, error 28, and the ipod will boot into recovery mode (the one with the connect to iTunes screen)
    if this happens, download TinyUmbrella (google it) and click "Kick Device out of Recovery", then jailbreak

    hope this helps, post if you need any more help
  5. enyahs

    enyahs Member

    Joined:
    Feb 8, 2009
    Messages:
    306
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    Sorry just saw this post. Im assuming because the 2g MC model doesnt need blobs, the 2g MB model doesnt either. Why when i try to upgrade to 4.0, does my ipod say that it upgraded fine and then say it needs to be resotred again. And when i do restore, no firmwares work besides 2.2.1

Share This Page