Confused- help me please :)

Discussion in 'iOS Jailbreak & Cydia' started by that_guy, Aug 15, 2010.

  1. that_guy

    that_guy New Member

    Joined:
    May 23, 2010
    Messages:
    102
    Likes Received:
    0
    Well I'm probaby being an idiot but for safety reasons I just need this answered- the big problem from apple lately has been that jailbreakme website thing hasn't it? And so they released a 4.0.2 patch however this only patched like newer devices- I have an iPod touch 2g which was included in the latch however I don't want to upgrade so I found out about saurik in cydia who has a PDF patch made and when I go into cydia it says for ios3 devices
    this is my problem- again I'm most likely being an idiot but I though this problem that apple reported was only a problem with the new 4.0 software - my iPod 2g is jailbroken on 3.1.2 - I think I'm safe but in the cydia PDF patch it says for ios3.

    So basically what I want to know is this problem reported by apple a problem with all devices- will my iPod 2g 3.1.2 need the patch or is this patch only needed on ios4 software?

    Thanks
  2. Soldier

    Soldier Active Member

    Joined:
    Aug 15, 2010
    Messages:
    788
    Likes Received:
    105
    you still need it.
  3. Bl1tzkrieg

    Bl1tzkrieg Active Member

    Joined:
    Jul 5, 2010
    Messages:
    1,878
    Likes Received:
    2
    Device:
    iPhone 4 (Black)
    Where did you see that this was only on iOS4? The patch saurik made is the same thing as the 4.0.2 update.. And you don't technically need it. We've gone 4 years without ever knowing anything about the PDF files

    Please Register or Log in to view images

  4. ChrisL

    ChrisL Well-Known Member

    Joined:
    Jul 26, 2008
    Messages:
    8,704
    Likes Received:
    159
    I believe all previous generations and firmwares will need it. Even if I'm wrong, just install the patch anyways, it doesn't take that much space.
  5. daitem11

    daitem11 Banned

    Joined:
    Aug 1, 2010
    Messages:
    130
    Likes Received:
    0
    Device:
    3G iPod touch
    you know theres a reason that 3.1.3 wasreleased to it was to patch taht same exploit
  6. Soldier

    Soldier Active Member

    Joined:
    Aug 15, 2010
    Messages:
    788
    Likes Received:
    105
    and its more secure
  7. that_guy

    that_guy New Member

    Joined:
    May 23, 2010
    Messages:
    102
    Likes Received:
    0
    I have to give you guys credit- that was incredibly quick....
  8. ChrisL

    ChrisL Well-Known Member

    Joined:
    Jul 26, 2008
    Messages:
    8,704
    Likes Received:
    159
    Right.. that's why the exploit was still there in 4.0. That makes sense, right?
  9. Charlie1016

    Charlie1016 New Member

    Joined:
    Jun 22, 2009
    Messages:
    48
    Likes Received:
    0
    Device:
    2G iPod touch
    Either way, we may have survived 4 years with the PDF vulnerability. But now people are more aware of it, the dangers are going to increase. So I would install and use the patch now.

    For anyone who is vulnerable to the PDF vulnerability and on iOS4; they should be extra careful, the "Font Bug" exploit Cosmex uses in http://www.jailbreakme.com makes the device even more vulnerable to attacks from malicious websites and shady Cydia applications. So it is always best to try to keep your security and safety at the highest standards.

    Kind Regards
    Charlie McShane
  10. tinyman392

    tinyman392 Super Moderator Staff Member

    Joined:
    Jul 10, 2008
    Messages:
    16,015
    Likes Received:
    1,380
    Device:
    iPhone 6
    I feel really bad for the first gen users that still have this hole. If I owned a first gen device I'd send an email to Steve Jobs asking him to release a patch for the PDF exploit to fix security flaws.

Share This Page