configure error: configure: error: cannot execute: /usr/local/bin/arm-apple-darwin-ld

Discussion in 'iOS Development' started by GunNam, Oct 22, 2008.

  1. GunNam

    GunNam New Member

    Oct 22, 2008
    Likes Received:
    Hello all, I've been struggling (and learning a lot) installing the toolchain on my Ubuntu 8.04.

    I was seeing the light at the end of the tunnel when I ran into this message:
    configure: error: cannot execute: /usr/local/bin/arm-apple-darwin-ld: check --with-ld or env. var. DEFAULT_LINKER
    make: *** [configure-gcc] Error 1

    Is this a deal breaker or is it something I can fix?

    I received the above error while following the directions from

    Specifically, this section (see bold)
    # Configure and make LLVM-GCC. Make sure that $LLVMOBJDIR and $HEAVENLY are set per the instructions above.

    $ mkdir -p build/llvm-gcc-4.0-iphone
    $ pushd build/llvm-gcc-4.0-iphone
    $ ../../llvm-gcc-4.0-iphone/configure --enable-llvm=`llvm-config --obj-root` \
    --enable-languages=c,c++,objc,obj-c++ --target=arm-apple-darwin --enable-sjlj-exceptions \
    --with-heavenly=$HEAVENLY --with-as=/usr/local/bin/arm-apple-darwin-as \
    --with-ld=/usr/local/bin/arm-apple-darwin-ld --enable-wchar_t=no
    $ make LLVM_VERSION_INFO=2.0-svn-iphone-dev-0.3-svn
    $ sudo make install

    One additional note I should mention is that I've installed (iphone_sdk_for_iphone_os_2.1__final) - iPhoneSDKHeadersAndLibs.pkg and NOT the MacOSX10.4.Universal.pkg as per the directions from ( I ran into some extraction issues and came across the information found here ( - thanks gojohnnyboi)

Share This Page