Change Leopard Version

Discussion in 'Mac & OS X' started by psychofish25, Jul 18, 2008.

  1. psychofish25

    psychofish25 New Member

    Joined:
    Nov 20, 2007
    Messages:
    259
    Likes Received:
    3
    I need version 10.5.3 to use the newest iPhone SDK, but I only have version 10.5.2 and I do not want to upgrade for various reasons. I was wondering if it would be possible for me to change a plist to make it APPEAR that I actually have 10.5.3 or even 10.5.4. I know this is possible on the iPhone and iPod Touch, so I was wondering if I could do it on my mac.

    Thanks,
    Jordan
  2. thechungster

    thechungster Super Moderator Emeritus

    Joined:
    Dec 8, 2007
    Messages:
    6,886
    Likes Received:
    4
    Device:
    iPhone 4 (Black)
    do this to change ur version plist.

    MacintoshHD-System-Library-Coreservices-SystemVersion.plist. and edit using textedit
  3. psychofish25

    psychofish25 New Member

    Joined:
    Nov 20, 2007
    Messages:
    259
    Likes Received:
    3
    Wow thanks! You clearly know what you're talking about.
  4. thechungster

    thechungster Super Moderator Emeritus

    Joined:
    Dec 8, 2007
    Messages:
    6,886
    Likes Received:
    4
    Device:
    iPhone 4 (Black)
    yep. since i have a mac as well, and i kinda know this stuff due to jailbreaking.
  5. engineers

    engineers New Member

    Joined:
    Nov 9, 2007
    Messages:
    113
    Likes Received:
    1
    Why don't you want to update?
  6. thechungster

    thechungster Super Moderator Emeritus

    Joined:
    Dec 8, 2007
    Messages:
    6,886
    Likes Received:
    4
    Device:
    iPhone 4 (Black)
    yeh why dont u? im on 10.5.4 and its still good

    Please Register or Log in to view images

  7. psychofish25

    psychofish25 New Member

    Joined:
    Nov 20, 2007
    Messages:
    259
    Likes Received:
    3
    Well I actually have a hackintosh and if I update it'll crash.

    Thanks so much though, the new SDK is now running on 10.5.2!
  8. thechungster

    thechungster Super Moderator Emeritus

    Joined:
    Dec 8, 2007
    Messages:
    6,886
    Likes Received:
    4
    Device:
    iPhone 4 (Black)
    ohh. im running mac so updates ftw!

    Please Register or Log in to view images

    . and no problem, just ask me if u have problems with macOSX. or ask Teslanaut, or someone with a mac

    Please Register or Log in to view images

  9. crizh4x

    crizh4x Active Member

    Joined:
    Sep 19, 2007
    Messages:
    4,474
    Likes Received:
    17
    Device:
    2G iPod touch
    look for a kalyway patched combo update... you didn't hear that from me

    Please Register or Log in to view images

  10. Nickll9009

    Nickll9009 New Member

    Joined:
    Sep 19, 2007
    Messages:
    1,367
    Likes Received:
    8
    Device:
    iPod touch
    But I did =p

Share This Page