Can't use SSH - "/bin/sh: Exec format error"

Discussion in 'iOS Jailbreak & Cydia' started by eozoon, Nov 28, 2007.

  1. eozoon

    eozoon New Member

    Joined:
    Oct 5, 2007
    Messages:
    107
    Likes Received:
    0
    Device:
    2G iPod touch
    Hi, I'm having problem with accessing my ipod through SSH / SFTP (Putty and Winscp), the connection window just closes immediately after entering the password.

    putty's log says the following:
    Code:
    login as: root
    root@192.168.1.147's password: 
    Last login: Thu Nov 29 13:21:44 2007 from 192.168.1.177
    
    /bin/sh: Exec format error
    
    SSH is enabled both in Service and via the SSH icon.

    I haven't done anything directly to SSH, but I was having some problem moving the apps to remove space limitation after upgrading to 1.1.2, and tried moving some files out manually (but it was YouTube.app that I just moved and restarted to see if it worked when I got the error, so it was probably unrelated to the apps move?).

    I still have access to the files via ibrickr and Finder, is there anyway I can fix this?

Share This Page