Can't upgrade 1G Touch from 2.2.1 to 3.0

Discussion in 'iPod touch' started by joes78, Jun 24, 2010.

  1. joes78

    joes78 New Member

    Joined:
    Jun 24, 2010
    Messages:
    1
    Likes Received:
    0
    Any idea on my my 1G touch keeps telling me 2.2.1 is the current version but I'm sure I should be able to upgrade ($10) to 3.0?

    Thanks,
    Joe

Share This Page