Can't restore :/

Discussion in 'iPod touch' started by xk2, Feb 7, 2010.

  1. xk2

    xk2 New Member

    Dec 5, 2009
    Likes Received:
    2G iPod touch
    Ok, so for the past two days I have been trying everything and I mean everything to restore my iPod to working order.

    I've used DFU mode to restore, recovery mode, I've uninstalled iTunes a billion times, uninstalled every apple product(I head that can sometimes fix it... so I tried it) and then reinstalled twice. I've managed to restore it twice now, but each time it gets restored it sits on the recovery mode screen and won't get out of recovery no matter what I do. I've tried another dock. The only thing I haven't tried is another computer, but I'm going to try and restore on another computer tommorow.

    It's a 32GB 2G iPod touch, and I am trying to restore to firmware 3.0(every time I download a newer firmware it iTunes says its corrupted).

    Any ideas as to how I could fix it?

    Oh and I've attached the error messages that get displayed when it fails to restore.

    Attached Files:

Share This Page