Can't Restore iPod 2G..

Discussion in 'iOS Jailbreak & Cydia' started by Phelopium, Jul 16, 2009.

  1. Phelopium

    Phelopium New Member

    Joined:
    Jul 16, 2009
    Messages:
    26
    Likes Received:
    0
    Device:
    2G iPod touch
    Hello everyone I've come for some help. I've searched endlessly but cannot find a solution to my problem.

    So I got a 2G 2.2.1 Touch and I'm trying to jailbreak untethered, everything is going perfect until I have to use iTunes to restore my firmware. I connect it with the SHIFT + Restore and it starts with "Preparing iPod for restore" and it does that for 10-15 minutes and then it stops with either a 1604/1603 or 1611 error. iTunes always detects it though and tells me to restore. I also got the newest version.

    I've tried all my usb jacks, re-downloading firmware (even from iTunes) re-installing iTunes, restarting computer multiple times, but nothing is working. All i have is a black screen or the iTunes logo with a usb picture under it.

    Can someone please help me out or link me to a thread where it was resolved. Thanks

    Now in iTunes it says I already have the most recent iPod firmware?? PLEASE HELP GUYS!! I've been at it since 10 am already
    ------------------double post merged------------------
    No one can help me? I cannot restore my firmware and can only see recovery and DFU mode. I get the same errors everytime
  2. Sparkyx

    Sparkyx Member

    Joined:
    Aug 30, 2008
    Messages:
    225
    Likes Received:
    0
    Device:
    iPhone 4S (White)
    use Redsn0w...put into DFU mode...jailbreak...then restore it.
  3. Phelopium

    Phelopium New Member

    Joined:
    Jul 16, 2009
    Messages:
    26
    Likes Received:
    0
    Device:
    2G iPod touch
    I tried redsn0w first but it didn't detect my ipod, I'll try again though i'm like 2 seconds away from returning it
  4. AlexTheKid!

    AlexTheKid! New Member

    Joined:
    Jul 16, 2009
    Messages:
    2
    Likes Received:
    0
    Device:
    2G iPod touch
    hmmm maybe you havent created your custom firmware properly do you have latest of redsnow or are you not them in admin mode if your using vista?
  5. Phelopium

    Phelopium New Member

    Joined:
    Jul 16, 2009
    Messages:
    26
    Likes Received:
    0
    Device:
    2G iPod touch
    i solved the problem, it was my firewall blocking it..... i felt retarded
  6. WhosCambo

    WhosCambo New Member

    Joined:
    Jul 29, 2009
    Messages:
    13
    Likes Received:
    0
    Device:
    iPhone
    I have same prob wont work either
  7. ipodtouchfan195

    ipodtouchfan195 New Member

    Joined:
    Jul 31, 2009
    Messages:
    11
    Likes Received:
    0
    Device:
    2G iPod touch
    u dont have to do that step. i didnt and i also have a 2g 3.0 just make sure that you downloaded the right firmware (should be around 270 MB) and browse for it IN REDSNOW and just then follow though the steps. and also if you get stuck will in redsnow when it says waiting for reboot unplug it and then plug it back in n then it will work. cuz that hapnd 2 me

Share This Page