Can't get jailbreak to work for 2g 2.21

Discussion in 'iPod touch Firmware 2.X' started by srsbznss, May 9, 2009.

  1. srsbznss

    srsbznss New Member

    Joined:
    May 9, 2009
    Messages:
    7
    Likes Received:
    0
    I just got my iPod Touch two days ago and I really wan't to jailbreak it but everytime I try to use QuickPwn I get an error message when I upload the firmware that says the firmware is either corrupted or not compatible with iPod. I know for sure that I have the reight firmware. Is there any other way to jailbreak an 2g iPod touch with 2.21 other than using QuickPwn? Please help if you can.
  2. jpga13

    jpga13 Banned

    Joined:
    Dec 4, 2007
    Messages:
    11,591
    Likes Received:
    435
    Device:
    iPad 3
    2.2.1 is 2nd gen ipod and needs redsnow or the like to jailbreak
  3. jairo5123

    jairo5123 New Member

    Joined:
    Feb 25, 2009
    Messages:
    32
    Likes Received:
    0
    Device:
    2G iPod touch
    Yes go to redsn0w.com and download it and second there is no quickown for ipod touch 2g
  4. PlasticPenguin

    PlasticPenguin New Member

    Joined:
    Apr 18, 2009
    Messages:
    84
    Likes Received:
    0
    Device:
    2G iPod touch
    use quickfreedom
  5. ipodtouchpwnd69

    ipodtouchpwnd69 New Member

    Joined:
    Mar 31, 2009
    Messages:
    314
    Likes Received:
    0
    Device:
    2G iPod touch
    dont use quickfreedom. it requiresa full restore (aka it will delete everything) use redsn0w its like quickpwn except for 2g. redwn0w.com
  6. leadergo

    leadergo Active Member

    Joined:
    Aug 2, 2008
    Messages:
    2,384
    Likes Received:
    6
    yeah, use Redsn0w. its much easier.

Share This Page