Cant Download Apps From Apstore?

Discussion in 'iPod touch' started by Bl4Ck.KiD..., Apr 14, 2010.

  1. Bl4Ck.KiD...

    Bl4Ck.KiD... New Member

    Joined:
    Dec 16, 2009
    Messages:
    26
    Likes Received:
    0
    Device:
    2G iPod touch
    im on my ipod touch 2g on 3.1.2 fw an everytime i go to download an app i get an error saying it cant take request ill post a screenshot if u guys want me to be more specific
  2. narwal13

    narwal13 Active Member

    Joined:
    Oct 12, 2009
    Messages:
    3,070
    Likes Received:
    6
    Device:
    5G iPod touch
    Try the following:

    1. Reboot
    2. Restart SpringBoard
    3. Enter Safe Mode and try downloading an app
    4. Download an app from iTunes on your PC/Mac, and try syncing the app over

    If none of those work...

    *gulp*

    5. Restore and re-jailbreak.

    Hope I helped.

    Please Register or Log in to view images

  3. Bl4Ck.KiD...

    Bl4Ck.KiD... New Member

    Joined:
    Dec 16, 2009
    Messages:
    26
    Likes Received:
    0
    Device:
    2G iPod touch
    i rebooted an respringed i never tried doing it in safe mode, how would i go into safe mode because i know it only comes up when u something messing up ur ipod
  4. narwal13

    narwal13 Active Member

    Joined:
    Oct 12, 2009
    Messages:
    3,070
    Likes Received:
    6
    Device:
    5G iPod touch
    Here's how to go into safe mode without you messing anything up.

    Go into Cydia

    Search 'SBSettings'

    Install it

    Reboot/Respring

    Slide horizontally from left to right, on the status bar (bar with time, battery)

    Tap power

    Tap Safe Mode
  5. Bl4Ck.KiD...

    Bl4Ck.KiD... New Member

    Joined:
    Dec 16, 2009
    Messages:
    26
    Likes Received:
    0
    Device:
    2G iPod touch
    ok thanks ill try it
  6. narwal13

    narwal13 Active Member

    Joined:
    Oct 12, 2009
    Messages:
    3,070
    Likes Received:
    6
    Device:
    5G iPod touch
    Cool. Let me know if it works or not!
  7. EkriirkE

    EkriirkE Member

    Joined:
    Mar 21, 2009
    Messages:
    92
    Likes Received:
    0
    Device:
    2G iPod touch
    Just a side question - you have synced with iTunes in the meantime, right?
  8. geekgrrl

    geekgrrl Member

    Joined:
    Oct 14, 2008
    Messages:
    954
    Likes Received:
    13
    Device:
    5G iPod touch
    I have a dozen app "upgrades" that will not download.

    There is a popup: This App Is Incompatible With This iPod touch
    P2.requiredCapabilities.thisAppRequires

    obviously written by Yoda.

    Is this the problem?

    I don't know what this notice is about, but why push "updates" that are not for the iPod Touch 2G version 3.0 and clutter my springboard with a "badge" notification?

    I don't see a way to refuse the "updates" or turn off the "badge" notification.

    I didn't intend to hijack the thread from the OP.

    It is only, maybe the incompatibility issue is the problem.

    I know I never got notifications for app upgrades before, that then said the upgrade is incompatible.

    Even more confusing: I have these apps from Apple Store. And these apps are for iPod Touch 2G and the upgrades is for the Touch 2G, at least some say so in the upgrade description.

    So, maybe the problem is the Apple Store, and not the OP.
  9. Bl4Ck.KiD...

    Bl4Ck.KiD... New Member

    Joined:
    Dec 16, 2009
    Messages:
    26
    Likes Received:
    0
    Device:
    2G iPod touch
    [removed]

    that's what I get when I try to download things
  10. Meikura

    Meikura Super Moderator Staff Member

    Joined:
    Jan 16, 2008
    Messages:
    6,081
    Likes Received:
    431
    Device:
    iPhone 4 (Black)
    Yeah, take out a certain application off those screenshots, then you can post them.

Share This Page