Can't Downgrade, I don't know what to do!

Discussion in 'iPod touch 1.1.x Jailbreak' started by ashconthegreat, Mar 29, 2008.

  1. ashconthegreat

    ashconthegreat New Member

    Joined:
    Jan 5, 2008
    Messages:
    15
    Likes Received:
    0
    I tried soft upgrading from jailbroken 1.1.2 to jailbroken 1.1.4, but something happened and it all restarted while downloading and then it was just a plain 1.1.4 ipod (not even wiggle was there) and now I don't know what to do as for jailbreaking.... I can't download ziphone for some reason...
    What should I do?
  2. cameleon1267

    cameleon1267 Member

    Joined:
    Oct 11, 2007
    Messages:
    494
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    use ilberty+ . It is a hard jailbreak and really easy.
    Don't waste your time with soft jailbreak now.
  3. wearmaize

    wearmaize Active Member

    Joined:
    Feb 13, 2008
    Messages:
    2,442
    Likes Received:
    13
    Device:
    iPhone 4S (Black)
    yeah iliberty is fast and there haven't been many reports of failed jb's like there were with ziphone.

Share This Page