can't buy a game "not compatible"

Discussion in 'iTunes App Store Games & Apps' started by Notasoccerstar09, Feb 15, 2009.

  1. Notasoccerstar09

    Notasoccerstar09 Member

    Joined:
    Oct 26, 2008
    Messages:
    59
    Likes Received:
    0
    Device:
    2G iPod touch
    i know that the reason is because i havent updated my ipod since i got it but if i update will i lose all hope of being to JB





    P.S. just in case i don't answer i do read all responses and i thank you for your help!

    Please Register or Log in to view images

  2. Collateral

    Collateral Active Member

    Joined:
    Sep 23, 2007
    Messages:
    1,974
    Likes Received:
    6
    Device:
    iPhone 3GS (Black)
    Um... all firmwares are jailbreakable... you can update..
  3. SOXWHO

    SOXWHO New Member

    Joined:
    Dec 3, 2008
    Messages:
    29
    Likes Received:
    0
    just spoof your FW
  4. Teslanaut

    Teslanaut Well-Known Member

    Joined:
    Sep 16, 2007
    Messages:
    15,588
    Likes Received:
    177
    Device:
    4G iPod touch
    Spoofing his Firmware is not going to make it that firmware.
  5. SOXWHO

    SOXWHO New Member

    Joined:
    Dec 3, 2008
    Messages:
    29
    Likes Received:
    0
    accually yes. i was trying to buy a game, it said cannot download because i needed 2.2.1, spoofed it to 2.2.1, and it downloads and the game works fine
  6. jpga13

    jpga13 Banned

    Joined:
    Dec 4, 2007
    Messages:
    11,591
    Likes Received:
    435
    Device:
    iPad 3
    he has 1.1.x firmware!!!!!!!!!!
  7. SOXWHO

    SOXWHO New Member

    Joined:
    Dec 3, 2008
    Messages:
    29
    Likes Received:
    0
    how? he has a 2G ipod touch?...
    i am confused

    Please Register or Log in to view images

  8. Notasoccerstar09

    Notasoccerstar09 Member

    Joined:
    Oct 26, 2008
    Messages:
    59
    Likes Received:
    0
    Device:
    2G iPod touch
    yes i do have 2.1.1 FW

    and i guess ill just update unless whats spoofing
  9. SOXWHO

    SOXWHO New Member

    Joined:
    Dec 3, 2008
    Messages:
    29
    Likes Received:
    0
    since you said you will jailbroken, use cydia, and search for FW changer, then type in under the custom section 2.2.1
  10. Notasoccerstar09

    Notasoccerstar09 Member

    Joined:
    Oct 26, 2008
    Messages:
    59
    Likes Received:
    0
    Device:
    2G iPod touch
    but the problem is that i dont want to jailbreak since i have to tether it to get it to start

Share This Page