Cannot upgrade from 2.1 to 2.2 (2g, 32gb)

Discussion in 'iPod touch Firmware 2.X' started by munchlax505, Feb 27, 2009.

  1. munchlax505

    munchlax505 New Member

    Joined:
    Feb 11, 2009
    Messages:
    8
    Likes Received:
    0
    Can anybody help me?....

    I've been trying to update my ipod 2g to 2.2 for at least 2 months now. I've tried everything I know.
    1. Direct update from itunes, error 9006 or something.
    2. Restore and update, also doesn't work.
    3. Direct link to the file online, always get decompression error.
    4. On one occasion, i successfully download the .ipsw but when i tried to use it on itunes, it shows the message: The iPod "iPod" could not be updated. An unknown error occurred (0xE800000B)
    5. I have iTunes 8
    6. When I try to use it on another computer, with the same network, It still doesn't download.
    .....
    7. I know that you think this is another 12 yr old kid thread who does not know how to use the ipod...guess what, i'm 14, and have basic knowledge, and know how to use my ipod...
  2. ipodtouchesrule

    ipodtouchesrule Active Member

    Joined:
    Jan 5, 2008
    Messages:
    1,009
    Likes Received:
    10
    Device:
    iPhone 4 (Black)
    Go here, but instead of downgrading you will be upgrading. So download the 2.2 firmware, and follow those steps.
  3. jpga13

    jpga13 Banned

    Joined:
    Dec 4, 2007
    Messages:
    11,591
    Likes Received:
    435
    Device:
    iPad 3
    If it's jailbroken you most likely need to restore to stock firmware and then select update in iTunes and it will take care of the firmware for you.
  4. munchlax505

    munchlax505 New Member

    Joined:
    Feb 11, 2009
    Messages:
    8
    Likes Received:
    0
    I'll try that ipodtouchesrule, but most likely I still cant download the firmware. Another question, does the file have to be 2.2 or 2.2.1?

    And no, the iPod is not jailbroken

Share This Page