Cannot Get To DFU Mode After...

Discussion in 'iPod touch 2G Jailbreak: redsn0w, 24kpwn, etc.' started by abc617, Aug 6, 2009.

  1. abc617

    abc617 New Member

    Joined:
    Aug 6, 2009
    Messages:
    5
    Likes Received:
    0
    Device:
    2G iPod touch
    I just tried to jailbreak my 2g iTouch and I followed the instructions using the QuickFreedom program. Everything worked fine until I tried to load the firmware (shift+restore in iTunes). From there I first got the 1604 error. So I tried it on a computer I had previously restored and upgraded the latest free firmware (2.2.1 I believe). But it turns out that got the 1604 error as well. I have a third computer that I never plugged the iTouch into before and well...this time I can't even get into DFU mode. I tried holding home+power button while it was plugged it and i got either
    -it quickly restarted itself
    -it would go black and to turn it back into recovery mode I would have to hold the power+home button for ~20 seconds

    other problems: while its plugged it I turn it off by holding the power button. But about 2 seconds after I turned on (while its still plugged in) it turns itself back on. So I can follow the traditional instruction of turning off the iTouch, holding power+home button while its off, because when its plugged in it always wants to turn itself back on.

Share This Page