Welcome to the iFans Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!

Cannot connect my PC and Iphone with SSH or Ifile web server

Discussion in 'iPhone' started by DAVID J BOROUGH, Aug 13, 2012.

  1. DAVID J BOROUGH

    DAVID J BOROUGH New Member

    Joined:
    Aug 13, 2012
    Messages:
    1
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    I am using WinSCP on my Windows XP to SSH to my Iphone 3gs. And it always says that it cannot connect. I am using the SCP protocol and the correct login, root and alpine.

    I think that firewalls are only for outside connections, but I turned off my Windows firewall just in case. I do not see any reason to believe that Netgear Rangemax router would not let everything thru. I do not know what I am talking about, just including any details that may be helpful. Everything is on the same wireless router, of course, but different devices use different wireless "networks", G, or N, according to its abilities. The router should consider those both part of the same network as neither one is set for "network isolation". My devices are NOT using the guest network.

    Thinking that maybe the password was the problem, I successfully used Ifile to put in the hashed password code for "alpine" for both root and mobile (just to keep it simple, will change it after success). However, WinSCP says it cannot connect before it even asks for the password, so that was never the constraint.

    The IP address is verified, and to keep things simple, I set the router to keep it fixed for this device at all times (192.168.1.3). The PC is at 192.168.1.5.

    Then, I was delighted to find that Ifile also has a web server set up on http://192.168.1.3:10000. Unfortunately, it ALSO does not connect on my network. And here I have an additional option, my Ipod Touch 2 on the same network, and it does not connect, either. And I have the 4 popular browsers, latest editions, on my PC. None of them connect. They all either say the web site cannot be displayed or else they time out after a minute or so. The Internet overall seems to work really well at high speed on all three devices. Come to think of it, I HAVE successfully used SSH before on this same network. It was between a different PC and my old Apple TV, but it was the same wireless router with essentially the same setup, no changes in particular that I can think of.

    Another little delighter was that I tried accessing the Ifile server from a web browser on the SAME device, and it worked just fine. It is a kind of proof of concept for me. I am really stumped. Any help would be appreciated.
  2. ValleyForge

    ValleyForge Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    11,073
    Likes Received:
    2,061
    Device:
    Nexus 4
    Did you install OpenSSH and reboot? I once forgot to do this, took me a few hours to discover my derp.

Share This Page