iOS 4.0 Can I use itunes 9.2 with jb itouch 2g?

Discussion in 'iOS Jailbreak & Cydia' started by sangahm, Jul 3, 2010.

  1. sangahm

    sangahm Member

    Joined:
    Jun 24, 2009
    Messages:
    33
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    I had to downgrade my itunes from 9.2 down to 9.1.1 in order to jb my 2G Itouch using blackra1n.

    Now my itunes syncs and backups from my itouch to my windows pc, but i cannot load any new songs or videos (they're grayed out in itunes). I also get an error about "cannot load sync services" or something similar which I'm sure is relate to the problem.

    I'm wondering if itunes 9.2 will fix this problem. My question is can I or should I upgrade to itunes 9.2 now? Will that mean I have to downgrade again if I have to jb again in the future?
  2. billyjoel

    billyjoel New Member

    Joined:
    Jun 13, 2010
    Messages:
    27
    Likes Received:
    0
    What model is your iPod how many GBs it has?
    Yeah you can go ahead and update iTunes it wont affect your jaibroken ipod in any ways

    You most likely are getting the the grayed out music on iTunes because your ipod is synced with another library, you can either erase all connect and and sync with iTunes or check the box where its says "manually manage music and videos"

    Also if your iPod is Not an MC model you can go ahead and restore to fw 4.0 and jailbreak with redsn0w
  3. sangahm

    sangahm Member

    Joined:
    Jun 24, 2009
    Messages:
    33
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    Thanks for the info. I have a 32G 2G MB model.

    I'll check out the suggestions on the library, which makes sense since when downgrading to 9.1.1, I essentially created a new one. But that doesn't explain why I can't delete all of my videos (i did) and copy new ones over from itunes. But I'll play around with the sync settings to see if I can figure something out.

    And I don't want to go to iOS4 due to issues with Tomtom 1.4.1. I've read reports that the latest version is bad, so I'll be staying on 3.12 until all of the issues are fixed.
  4. Eclipse

    Eclipse Member

    Joined:
    Jun 24, 2010
    Messages:
    380
    Likes Received:
    0
    Device:
    4G iPod touch
    I jailbroke 3.1.2 with spirit and itunes 9.2; You didn't even need to downgrade rofl, you screwed urself over. Just upgrade back to 9.2
  5. Nickmadkiller

    Nickmadkiller Well-Known Member

    Joined:
    May 16, 2010
    Messages:
    4,274
    Likes Received:
    84
    Device:
    iPhone 4 (White)
    Research is always useful before downgrading anything.

Share This Page