Can I hack a NEW iPod touch that came preinstalled with 1.12?

Discussion in 'iPod touch 1.1.x Jailbreak' started by jacobwaldo2, Jan 11, 2008.

  1. jacobwaldo2

    jacobwaldo2 New Member

    Joined:
    Oct 21, 2007
    Messages:
    34
    Likes Received:
    0
    Hello, I was a proud owner of a jailbroken ipod touch until I sold it the other day so I could buy myself a 16 gig (or whatever one they MAY come out with on Tuesday at the mac world conference) The thing is, I know someone who just bought an iPhone but said they could not unlock it or jailbreak it because it comes preinstalled with 1.1.2 and so it can't be downgraded. Is this true? And if it is, will it also apply to the ipod touch because I will be buying a new one next week (which will come with 1.1.2). Also, if this is true, is there a way around it?
  2. Manic Nimrod

    Manic Nimrod Well-Known Member

    Joined:
    Nov 26, 2007
    Messages:
    8,769
    Likes Received:
    149
    No its not true, you can downgrade, just click onto the search button
  3. IKON

    IKON New Member

    Joined:
    Oct 8, 2007
    Messages:
    29
    Likes Received:
    0

    You can jailbreak an iPhone with 1.1.2, you only have to downgrade first to 1.1.1.
    Only to use the phone functions you need a "turbosim".

    I used a "nextsim 3" on an iPhone US for use in Belgium. Works perfectly.
  4. deveelx

    deveelx New Member

    Joined:
    Dec 20, 2007
    Messages:
    392
    Likes Received:
    11
    i can give you a link where you can download the iPod touch Firmware 1.1.1. PM me if you want it. I can also give you link on tutorial on how to dwngrade 1.1.2 just in case you want it.

Share This Page