iOS 4.0 Camera App is not working

Discussion in 'iOS Jailbreak & Cydia' started by ircmaster, Aug 10, 2010.

  1. ircmaster

    ircmaster New Member

    Joined:
    Mar 2, 2009
    Messages:
    16
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    I recently jailbroke to 4.0 and I've been fairly satisfied with it. However, yesterday I noticed that my camera app stopped working indefinitely. I have no idea how this happened and I'm not sure if it was because I downloaded something new from Cydia. I tried to delete all the things that I thought might cause the problem but I was unable to find a way to fix the problem.

    What I have tried so far besides deleting new Cydia downloads is putting the phone into safe mode manually and testing it and I also disabled all themes. I also downloaded another camera app from the app store to see if it works but the app keeps on crashing, I really don't know what to do.

    Any tips on what I can do?

    I'm using an iPhone 3GS

    Edit: let me note that the app opens up to the point where the shutter shows up and then it turns to a black screen and goes back to springboard. I was actually able to get the app running for a few seconds about an hour earlier before it crashed.
  2. Nickmadkiller

    Nickmadkiller Well-Known Member

    Joined:
    May 16, 2010
    Messages:
    4,274
    Likes Received:
    84
    Device:
    iPhone 4 (White)
    If all else fails a restore should fix it.
    ------------------double post merged------------------
    It may be a hardware issue but I wouldn't know since I don't use an iPhone.
  3. Oliver Barker

    Oliver Barker New Member

    Joined:
    Apr 4, 2008
    Messages:
    1,284
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    If the problem persists on a fresh unjailbroken firmware without anything on it (just restored, not restored from a backup) then its likely a hardware problem. Take it back, they should refund or replace it.

Share This Page