iOS 4.1 Bootrom expoloit yay!!!!! 4g support?

Discussion in 'iOS Jailbreak & Cydia' started by kzr22, Sep 8, 2010.

  1. kzr22

    kzr22 New Member

    Joined:
    Dec 30, 2008
    Messages:
    460
    Likes Received:
    0
    Device:
    2G iPod touch
    hey, im not very knolegeable about jailbreaking im wondering when the exploit comes out does that mean it will definately work on the 4g? or would it have to be found differently or something?
  2. FaL LeGeNd

    FaL LeGeNd Member

    Joined:
    Jul 29, 2010
    Messages:
    391
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Yes, if it is a bootrom exploit, the iPod Touch 4G would be pwnd for life because it's a hardware exploit, meaning Apple cannot patch it without updating the hardware in a device, so only new models after the jb is released would not be jailbroken.
  3. kzr22

    kzr22 New Member

    Joined:
    Dec 30, 2008
    Messages:
    460
    Likes Received:
    0
    Device:
    2G iPod touch
    WOOOOOO ty that is awesome news!!!

    edit: wait if thats true then why is the 1g not instantly jailbroken on 4.1/4.2????
    is taht only for 4.0?
  4. FaL LeGeNd

    FaL LeGeNd Member

    Joined:
    Jul 29, 2010
    Messages:
    391
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    The iPod Touch 1G is not supported by iOS 4. Therefore, they are pwnd4life on 3.1.3.
  5. kzr22

    kzr22 New Member

    Joined:
    Dec 30, 2008
    Messages:
    460
    Likes Received:
    0
    Device:
    2G iPod touch
    ok so 1g was the only thing pwnd for life ever and 4g would be next, so that would mean for all firmwares supported by 4g a jailbreak would be possible? the 3g and 2g never have been??
    ------------------double post merged------------------
    it says blackrain was a bootrom exploit so by that logic shouldnt the 2g be already pwnd on 4.1?
  6. FaL LeGeNd

    FaL LeGeNd Member

    Joined:
    Jul 29, 2010
    Messages:
    391
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Technically it is, every device up to the 3G (New bootrom) and iPod Touch 3G is pwnd4life. But RedSn0w (the jailbreak tool for pwnd4life devices) hasn't been updated yet to fully support 4.1 yet. (Blackra1n only worked up until 3.1.2). So jailbreaking with redsnow before it is updated causes cydia to be unusable and therefore ruins the point of the jailbreak.
  7. Dkapod

    Dkapod New Member

    Joined:
    Aug 23, 2010
    Messages:
    57
    Likes Received:
    0
    With new device like iphone4 and ipod touch 4th gen, what jail break to be used? is it the bootrom? and what is pawn4life?
  8. FaL LeGeNd

    FaL LeGeNd Member

    Joined:
    Jul 29, 2010
    Messages:
    391
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Right now, there is no jailbreak for the iPod Touch 4G (I believe it ships with 4.1). If you have 4.0.1 you can go to http://www.jailbreakme.com ON YOUR DEVICE to jailbreak. 4.0.2 patches the hole jailbreak me uses. So 4.0.2 and up can't be jailbroken.

    Pwnd4life means that for the rest of the life of that device, it can be jailbroken on any firmware, because the hardware is exploited. Meaning Apple can't patch it unless they update the hardware. Therefore, any device with the old hardware, is pwnd4life.
  9. TchnclFl

    TchnclFl New Member

    Joined:
    Sep 7, 2010
    Messages:
    631
    Likes Received:
    0
    Device:
    4G iPod touch
    Yes indeed. And 4.2 supposedly comes out some time next month.
  10. Dkapod

    Dkapod New Member

    Joined:
    Aug 23, 2010
    Messages:
    57
    Likes Received:
    0
    wat r blobs and shs?
    ------------------double post merged------------------
    and wat r thethered and unthetherd? thanks

Share This Page