Best firmware to use on a jailbreaked iPod?

Discussion in 'iPod touch' started by RAFAMP, Mar 9, 2008.

  1. RAFAMP

    RAFAMP New Member

    Joined:
    Jan 13, 2008
    Messages:
    27
    Likes Received:
    0
    Hello

    Which firmware should i get on my iPod touch? i heard that with 1.1.4 you'll lose apps compatibility, so should i go with 1.1.3?

    Cheers
  2. canine

    canine New Member

    Joined:
    Jan 9, 2008
    Messages:
    84
    Likes Received:
    0
    Device:
    2G iPod touch
    i would have to say 1.1.2 because to jailbreak 1.1.3 u have to be in 1.1.2 and if you want to jailbreak 1.1.4 you have to downgrade jailbreak and all that stuff 1.1.2 is like a fork in a road from 1.1.2 you can go anywhere also many more apps are compatible with it than the new firmwares. so if a new firmware comes out you will be able to jailbreak it.

    Please Register or Log in to view images

    Please Register or Log in to view images

    Please Register or Log in to view images

    Please Register or Log in to view images

  3. tafga

    tafga New Member

    Joined:
    Jan 11, 2008
    Messages:
    28
    Likes Received:
    0
    1.1.3 and 1.1.4 are almost same only some bug fixes and you wont lose app compability..so youll better go on 1.1.4 imo
  4. RAFAMP

    RAFAMP New Member

    Joined:
    Jan 13, 2008
    Messages:
    27
    Likes Received:
    0
    Please guys, more opinions!
  5. ipodtouchesrule

    ipodtouchesrule Active Member

    Joined:
    Jan 5, 2008
    Messages:
    1,009
    Likes Received:
    10
    Device:
    iPhone 4 (Black)
    well 1.1.1 is the easiest to jailbreak but it doesn't have a lot of application capability anymore because of the newer firmware but 1.1.3 and 1.1.4 are easy to jailbreak to so i would just do 1.1.4 or 1.1.3. i am running on 1.1.4 jailbreak

    Please Register or Log in to view images

    Please Register or Log in to view images

  6. RAFAMP

    RAFAMP New Member

    Joined:
    Jan 13, 2008
    Messages:
    27
    Likes Received:
    0
    Do you have any problems with compatibility on 1.1.4?
  7. randomronik

    randomronik New Member

    Joined:
    Jan 25, 2008
    Messages:
    30
    Likes Received:
    0
    I'm running 1.1.1 and i run all applications fine. there hasnt been a application yet that has failed me because of my firmware. its pretty smooth.
  8. njdevildude4

    njdevildude4 New Member

    Joined:
    Nov 13, 2007
    Messages:
    120
    Likes Received:
    3
    what is wrong with 1.1.1 capability's , i have it and everything works fine with it

    i would say 1.1.1 but thats just me i guess
  9. RAFAMP

    RAFAMP New Member

    Joined:
    Jan 13, 2008
    Messages:
    27
    Likes Received:
    0
    Why use 1.1.1 instead of 1.1.4?
  10. ur_so_beautiful

    ur_so_beautiful New Member

    Joined:
    Feb 15, 2008
    Messages:
    984
    Likes Received:
    16
    personal favorite is 1.1.3 beats all the rest

    Please Register or Log in to view images

Share This Page