Backgrounder app not working?

Discussion in 'iPhone' started by dieselboy27, Nov 4, 2008.

  1. dieselboy27

    dieselboy27 New Member

    Joined:
    Apr 8, 2008
    Messages:
    339
    Likes Received:
    1
    I have been finding that backgrounder does not seem to work. I have an app running, for example fstream, and press the home button to enable backgrounder. When I open another app, the fstream app closes/crashes and no longer streams my station. Seems to me that backgrounder doesn't work as advertised, or at least the way I imagined it would.
  2. murphmanny

    murphmanny Banned

    Joined:
    Sep 19, 2007
    Messages:
    5,250
    Likes Received:
    3
    maybe some apps don't work with backgrounder
  3. brownbox

    brownbox New Member

    Joined:
    Dec 28, 2007
    Messages:
    114
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    i can confirm that backgrounder does infact work fine with fstream.
    Maybe reinstall backgrounder?
  4. dashwood03

    dashwood03 New Member

    Joined:
    Oct 17, 2008
    Messages:
    671
    Likes Received:
    0
    its a little buggier.
  5. giannaros

    giannaros New Member

    Joined:
    Sep 1, 2008
    Messages:
    775
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    If you have Intelliscreen installed, disable the fast-launching feature.
  6. dieselboy27

    dieselboy27 New Member

    Joined:
    Apr 8, 2008
    Messages:
    339
    Likes Received:
    1
    I do not have intelliscreen installed. I will try reinstalling backgrounder though.

    At least no one said to restore.
  7. bulungula

    bulungula New Member

    Joined:
    Jul 20, 2008
    Messages:
    235
    Likes Received:
    0
    I guess it's a resource problem. In FStream, you can decide what buffer size you want. with a small buffer, backgrounder works a little better than with the biggest buffer.

    In the background, applications wont get as much ram and processing time like in the "foreground".
  8. gsantoro

    gsantoro New Member

    Joined:
    Apr 6, 2010
    Messages:
    4
    Likes Received:
    0
    Device:
    iPhone
    the settings are really weird for backgrounder. I had to F*$K around with the settings to get it just right. The two apps I was using to test were 2 classical music radio station apps from the apple app store. Here is what worked for me:

    in the global section: 'backgrounding method: backgrounder (run as if in foreground"
    "options for backgrounder: fall back to native: ON"
    "backgrounding state: enable at launch: OFF, Stay enabled: ON"
    "Indicate state via: Badge: ON, Status bar icon: ON"
    Miscellaneous: Minimize on toggle: OFF"

    These are the settings that finally worked. After setting it just like that, I opened the first app "KUSC classical" and held the home button to background it. I stopped the music and minimized the app, it had a black badge indicating it's in background. I opened the second app "KDFC classical" and held the home button to background it. I minimized it, and both apps had black badges indicating they're in background. I went ahead to test it further and opened another app "sushi" or whatever from the app store, put it in background and then minimized, and all 3 apps had the black backgrounder badge. I then opened up each one and held the home key to disable backgrounding for each one.

    If the settings above don't work, I have no idea what will for you. They work for me. I will be saving the settings onto a word program in case I need to restore ever again.

Share This Page