<b>Can't jailbreak, help please!!</b>

Discussion in 'iPod touch 1.1.3 Jailbreak' started by redkupo, Mar 3, 2008.

  1. redkupo

    redkupo New Member

    Mar 3, 2008
    Likes Received:
    i have an ipod Touch 16g originally 1.1.1, and upgraded to 1.1.3, i tried to jailbreak it but it gave me an BSD error, so i restored it (done this 3 times) and the last time i did it, iTunes forced me to upgrade it to 1.1.4 firmware (didn't know there was a 1.1.4 for ipod touch) does this means that i won't be able to jailbreak it??, or there is another method? what do i do?, i'm preety frustrated. thanks.

    oops, i almost forgot to tell you, i used ziPhone2.5c, at least that was the last time i did it. the other timer i used older versions of ziphone. hope you can help me
  2. dwonder3

    dwonder3 Well-Known Member

    Oct 30, 2007
    Likes Received:
    iPod touch
    You can from downgrade 1.1.4 Search 1.1.4 downgrade. Not sure how you do it but give it a shot. If you have wifi try using iJailbreak mobile

Share This Page