iPhone 3G ATT sim dont work on iPhone 3G

Discussion in 'iPhone' started by rnhib25, Jun 12, 2009.

  1. rnhib25

    rnhib25 New Member

    Joined:
    Mar 21, 2008
    Messages:
    21
    Likes Received:
    0
    When i stick a regular ATT sim card into it, it doesn't find any service the phone is running Firmware 2.2.1 baseband 2.30 jailbroken... i thought when you jailbreak it activate the phone and the phone will work with any ATT sim
  2. michaelsipod

    michaelsipod New Member

    Joined:
    Jan 26, 2009
    Messages:
    431
    Likes Received:
    0
    Device:
    iPhone
    jailbreaking allows you to shh and run thrid party apps, you have to unlock the phone to use any sim card
  3. rnhib25

    rnhib25 New Member

    Joined:
    Mar 21, 2008
    Messages:
    21
    Likes Received:
    0
    i cant unlock it its running 2.2.1 i got a turbosim for it but keep messing up
  4. ZombieKiller

    ZombieKiller Banned

    Joined:
    Oct 21, 2007
    Messages:
    3,740
    Likes Received:
    30
    Device:
    iPhone 3G (White)
    No... you can unlock it at 2.2.1.

    Use QuickPwn
  5. rnhib25

    rnhib25 New Member

    Joined:
    Mar 21, 2008
    Messages:
    21
    Likes Received:
    0
    i no u can run it on the 2g but not sure on the 3G
  6. sickamore

    sickamore New Member

    Joined:
    Mar 17, 2009
    Messages:
    205
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    its not simple go to the unlocking guide. Check the info there to better understand.
  7. michaelsipod

    michaelsipod New Member

    Joined:
    Jan 26, 2009
    Messages:
    431
    Likes Received:
    0
    Device:
    iPhone
    he has an iphone 3g on 2.2.1, which means he has baseband 2.3.0 which means, he could try and use fuzzy bootloader(i think that's what its called) from cydia and try to downgrade his baseband and use yellowsnow
  8. rnhib25

    rnhib25 New Member

    Joined:
    Mar 21, 2008
    Messages:
    21
    Likes Received:
    0
    fuzzy bootloader does not work on my phone i think it need to be 5.08 mine is 06.02 i believe
  9. michaelsipod

    michaelsipod New Member

    Joined:
    Jan 26, 2009
    Messages:
    431
    Likes Received:
    0
    Device:
    iPhone
    Oh that sucks, you can buy a turbosim
  10. rnhib25

    rnhib25 New Member

    Joined:
    Mar 21, 2008
    Messages:
    21
    Likes Received:
    0
    LOL i do ahe a turbo sim im using for my tmobile service but im selling to it my friend which have ATT and i dont want to give them my TURBOSIM because it keep messing up ( like say no simcard installed so u ahve to take it out and place it in a phone that wrks and make a call and put the sim back int he iPhone lol) i thought ATT sim will work on the iphone if its just jailbroken lol

Share This Page