Apps won't sync, iTunes gives inconsistent error messages

Discussion in 'iPod touch' started by justonesp00lturn, Jul 19, 2010.

  1. justonesp00lturn

    justonesp00lturn Member

    Joined:
    May 21, 2008
    Messages:
    248
    Likes Received:
    8
    Device:
    5G iPod touch
    Okay, I've searched for the answer to this issue all over this site and the internet and no one seems to be having the same issue, or if they are, I can't find it. Sorry if this is the wrog forum; I'm having multiple issues and questions, so I thought this might be the most generic place for it.

    I got an iPod Touch 3G over the weekend. I previously had a 1G touch, jailbroken.

    When I plugged in the new iPod for the first time, I selected "restore from backup" because I wanted it to have my app data on the new iPod. Later, it was suggested to me via this site to set it up as a new iPod to prevent the jailbreak data from being on the new iPod and thus voiding my warranty. So, I restored the new iPod and set it up as a new iPod.

    That's when the problems happened.

    It took me about 20 tries to restore the iPod. It would get to the end of the process, and then give me an error saying the iPod was unplugged before it could finish. Obviously, I did no such thing. I followed the instructions on Apple's site, and finally, I restarted my computer, restored, and it worked fine.

    But now, if I try to add apps through iTunes, various apps just will not sync to the iPod. Most of them were added just fine, but several simply refuse (though I can download them on my device just fine.) The apps that initially refused were:
    WeDict
    Eliminate Pro
    MotionX Dice
    EXO-Planet

    I eventually installed Eliminate through the app store on my device, and it hasn't had any issues since. I never got the others to work.

    Now, I've downloaded another app trhough iTunes, Dictionary.com, and it's also refusing to sync. The thing is, it gives me different error messages. Usually I get a coded error which takes me here: http://support.apple.com/kb/TS1702

    I had tried all of those things when I first had the issue. They don't solve the problem in the least bit. And then, sometimes I get an error which reads "the app was not added to the iPod because its resources have been modified." I have no idea what this means. Searching in Google, the only results I got for this message ever occurring had to do with either compiling beta versions of apps (which I'm obviously not doing) or with jailbroken devices (which mine isn't.)

    I really can't seem to figure this out. Did something go wrong with my device? I never had these issues with my old iPod, but this one is brand new, so I have a hard time believing its broken.

    I'd also like to know if I can get my old app data off of my iPod 1G onto the 3G without there being any trace of it having been jailbroken, in app data or background data or whatever (if you couldn't tell, I'm not incredibly tech-savvy; I have a pretty rudimentary knowledge of how all of this works.) And if such data does transfer to my new device, will it void my warranty? I haven't and don't plan on jailbreaking this new device while the warranty is active, but I'm worried that I'll try to take it back and the Apple guys will refuse it due to data leftover from jailbreaking a diferent device, or something along those lines.

    Thanks for the time and for any advice. I'm incredibly frustrated over this whole issue. I should also mention that I have the latest version of iOS (4.0,) the latest version of iTunes (9.1.2) and the latest versions of all apps in question.

    Edit: Fixed. I turned off my firewall, and all of the problematic apps synced (saync?) just fine.

    But if anyone has an answer regarding my jailbreak data question, or perhaps knows what I can do to make it so I don't have to turn off my firewall every time I wish to sync, it would be greatly appreciated.

Share This Page