apps on ipod touch 1g?

Discussion in 'iPod touch' started by madi, Jan 11, 2009.

  1. madi

    madi New Member

    Joined:
    Jan 11, 2009
    Messages:
    8
    Likes Received:
    0
    i'm new to the whole ipod touch thing so please be nice.

    i just bought a refurbished 1g ipod touch from apple and i've been trying to get things straight before i get it in the mail this week. if i don't update the firmware to the news 2.whatever one, will i still be able to download apps to it? i'll just have to download them connected to my pc, not straight from the ipod, right?
  2. chiefkeckers

    chiefkeckers New Member

    Joined:
    Nov 20, 2007
    Messages:
    43
    Likes Received:
    0
    to download and use apps from apple you have to be using firmware 2.0 or later
    2.2 is very good and worth it.
  3. madi

    madi New Member

    Joined:
    Jan 11, 2009
    Messages:
    8
    Likes Received:
    0
    which one is the one you have to buy?
    is 2.0 free? an 2.2 the one you have to buy.
  4. nikj14

    nikj14 Active Member

    Joined:
    Sep 4, 2008
    Messages:
    1,313
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    if your ipod comes with 1.1.4 you will need 2 pay to upgrade to 2.x.x.
    BTW all firmwares are jailbreakable on the 1G
  5. madi

    madi New Member

    Joined:
    Jan 11, 2009
    Messages:
    8
    Likes Received:
    0
    okay then, which is better, jailbreaking, or using the app store? and which is easier? because my boyfriend tried to tell me how to jailbreak it but i got really confused.
  6. pjbarnoy

    pjbarnoy New Member

    Joined:
    Oct 5, 2007
    Messages:
    159
    Likes Received:
    1
    Device:
    iPod touch
    The thing is, on the 1st generation ones, you can Jailbreak, AND have apps from the App Store. You don't even have to choose between them!

    If the iPod comes with firmware 1.x.x., however, you do have to pay to upgrade to 2.x.x. to have the App Store. Basically every firmware to date is Jailbreak-able on the 1st generation touch.
  7. madi

    madi New Member

    Joined:
    Jan 11, 2009
    Messages:
    8
    Likes Received:
    0
    so if i jailbreak it, it'll be able to use the app store?
    i'm sorry, i probably sound so retarded. =/
  8. awal

    awal Well-Known Member

    Joined:
    Jan 2, 2008
    Messages:
    4,764
    Likes Received:
    31
    Device:
    iPhone 4S (White)
    If you jailbreak 2.0 or higher, yes.
  9. madi

    madi New Member

    Joined:
    Jan 11, 2009
    Messages:
    8
    Likes Received:
    0
    oh...
    well... if i jailbreak it, where do i go to get applications?
    and are the applications that are in the app store available for jailbroken ipods?
  10. awal

    awal Well-Known Member

    Joined:
    Jan 2, 2008
    Messages:
    4,764
    Likes Received:
    31
    Device:
    iPhone 4S (White)
    If you jailbreak 1.1.x, you'll get third party apps from Cydia or Installer. If you jailbreak 2.x.x, you can still get some apps from Cydia, but many developers moved on to the App Store rather than porting their apps to the new firmwares. App Store applications are only available on firmwares that can actually run the App Store (2.x.x).

Share This Page