Application not compatible with this iPhone?

Discussion in 'iPhone' started by Riddler, Feb 22, 2009.

  1. Riddler

    Riddler New Member

    Joined:
    Jun 3, 2008
    Messages:
    26
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    this message comes up when i try and download certain things from the App Store but it doesnt make sense because it is basic stuff like facebook that thousands o people have. Anyone else experiencing this issue? Any advice?
  2. Duykur

    Duykur Banned

    Joined:
    Mar 24, 2008
    Messages:
    1,674
    Likes Received:
    0
    can you give more info i.e.
    what is the actual error message?
    what FW are you running?
    and what is the app?
  3. Riddler

    Riddler New Member

    Joined:
    Jun 3, 2008
    Messages:
    26
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    error message= NOT COMPATIBLE This application is not compatible with this iPhone.

    i am running 2.1

    the app is facebook but it also happens on others such as monopoly, kitty cannon, ect.
  4. Duykur

    Duykur Banned

    Joined:
    Mar 24, 2008
    Messages:
    1,674
    Likes Received:
    0
    Hmmmm, very interesting.
    Never seen this before. Restore you iPhone and reload the apps and see if it works.
  5. Riddler

    Riddler New Member

    Joined:
    Jun 3, 2008
    Messages:
    26
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    My iPhone is jailbroken would that have anything to do with it?

    or the apps i am trying to install are set up for firmware 2.2?
  6. spoonforknife

    spoonforknife Retired Moderator

    Joined:
    Nov 15, 2007
    Messages:
    6,896
    Likes Received:
    317
    Well upgrade to 2.2.1. See what happens.
    It has nothing to do with the jailbreak.
  7. Riddler

    Riddler New Member

    Joined:
    Jun 3, 2008
    Messages:
    26
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    ahh!! i dont wanna rejailbreak but ill try it
    ------------------double post merged------------------
    ok i updated to 2.2 and its working alright. thanks for the help

Share This Page