Apple Squeezing out 3.1.2 firmware

Discussion in 'iTunes App Store Games & Apps' started by dlstc, Apr 18, 2010.

  1. dlstc

    dlstc Member

    Joined:
    Oct 30, 2008
    Messages:
    287
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    I've run into a few instances where I couldn't download an app or an update for an app because I wasn't running 3.1.3 firmware. I work around by using iTunes on my computer. I'm thinking of upgrading my Touch 3g, just so I can try those apps. My iPhone 3GS is 3.1.2 and jailbroken. Any other options out there?

    Way to go Apple. :/
  2. ChrisL

    ChrisL Well-Known Member

    Joined:
    Jul 26, 2008
    Messages:
    8,704
    Likes Received:
    159
    When you update the apps on your computer, you can use them right?
  3. dlstc

    dlstc Member

    Joined:
    Oct 30, 2008
    Messages:
    287
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    It will download to my library, but won't sync to my phone.
  4. ChrisL

    ChrisL Well-Known Member

    Joined:
    Jul 26, 2008
    Messages:
    8,704
    Likes Received:
    159
    Oh hmm.. I think there is a way to make the app think it needs 3.1.2 instead of 3.1.3, not sure how though, but I remember seeing a guide about it.

    Edit: This wasn't the guide that I was thinking about, but you could try this:
    http://www.redmondpie.com/iphone-3.1.3-fake-firmware-version-9140442/
  5. XxRedRumxX

    XxRedRumxX Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    6,666
    Likes Received:
    1,079
    Device:
    Samsung Galaxy Nexus
    FW 3.1.3 app on Cydia....Tricks itunes and app store into thinking your running 3.1.3
  6. iPwn

    iPwn Community Development Staff Member

    Joined:
    Feb 5, 2010
    Messages:
    7,336
    Likes Received:
    525
    Device:
    Nexus 4
    Yeah it's pro. there's this other app that lets you spoof it to whatever you want, though, like 5.2 beta 1 or 1.1.2.
  7. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S
    Or you could just use iFile.
  8. NitroBum

    NitroBum Active Member

    Joined:
    Feb 23, 2009
    Messages:
    1,549
    Likes Received:
    12
    Device:
    iPhone 4S (Black)
    thats what i was gonna say!

    what's an example of an app that requires 3.1.3?
  9. SoBe

    SoBe Banned

    Joined:
    Sep 1, 2009
    Messages:
    3,788
    Likes Received:
    1
    Device:
    2G iPod touch
    How would you do it via iFile?
  10. NitroBum

    NitroBum Active Member

    Joined:
    Feb 23, 2009
    Messages:
    1,549
    Likes Received:
    12
    Device:
    iPhone 4S (Black)
    hmmm... i was gonna say its in the itunesmetadata.plist, but i just checked and it's not there. i've seen it before but it's been a while. i'll post here if i find it.

Share This Page