anyone get lighttpd working on 2.0?

Discussion in 'iPod touch Firmware 2.X Jailbreak' started by jwraider, Jul 26, 2008.

  1. jwraider

    jwraider New Member

    Joined:
    Jan 31, 2008
    Messages:
    2
    Likes Received:
    0
    Hello,

    I decided to upgrade becuase I saw a webserver was available for 2.0 but I'm not having much luck setting it up. All the info for configuring lighttpd seems to point to previous ipod OS versions. For example the root directory for web content doesn't exist after installing the app and restarting the ipod.

    Anyone able to point me in the right direction? I appreciate it I use the webserver to maintain work related info which comes in very handy!

    Thanks!
  2. bitstop

    bitstop New Member

    Joined:
    Jul 26, 2008
    Messages:
    2
    Likes Received:
    0
    I have tried but no luck yet...

    I created a lighttpd.conf file:
    "dir-listing.activate = "enable"

    server.document-root = "/private/var/root/Media/Cache"

    server.port = 80

    mimetype.assign = (
    ".html" => "text/html",
    ".txt" => "text/plain",
    ".jpg" => "image/jpeg",
    ".png" => "image/png"
    )"

    I have placed this file in the /usr/sbin directory and then cd /usr/sbin
    Then typed:

    lighttpd -D -f lighttpd.conf

    I then get a message that says server started.

    Then set the iphone browser to "http://127.0.0.1" and got no connection.

    then after no luck i go ctrl-c and shutdown the server again.

    Any suggestions?
  3. geiman

    geiman New Member

    Joined:
    Nov 27, 2007
    Messages:
    47
    Likes Received:
    0
    Device:
    iPod touch
    hey, if you guys still need help getting lighttpd set up, send me a pm

Share This Page