Any success with 3.0 2g jailbreak?

Discussion in 'iPod touch Firmware 3.0 Jailbreak' started by Cl8rs, Jun 20, 2009.

  1. Cl8rs

    Cl8rs Active Member

    Joined:
    Apr 20, 2009
    Messages:
    1,760
    Likes Received:
    1
    Device:
    2G iPod touch
    Has anyone been successful with the iPod touch 2g 3.0 jailbreak? Should I wait to jailbreak mine?
  2. kyle hultgren

    kyle hultgren Member

    Joined:
    Apr 15, 2009
    Messages:
    609
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    yes i have and no dont wait
  3. Joeyl10

    Joeyl10 New Member

    Joined:
    Dec 5, 2008
    Messages:
    129
    Likes Received:
    0
    Device:
    2G iPod touch
    I would honestly wait a bit more, everything's going through the classic "wait, new OS? OHSHI--" period. There's a few things which still need fixing.
  4. TheIpodTeen

    TheIpodTeen New Member

    Joined:
    Jan 4, 2009
    Messages:
    113
    Likes Received:
    0
    Device:
    4G iPod touch
    Wel....


    Way too many...

    I'm going to re-jailbreak 3.0 too see how it goes, my first attempt lead to my device not even booting..
  5. privateeye0

    privateeye0 New Member

    Joined:
    Mar 12, 2008
    Messages:
    2
    Likes Received:
    0
    Just used the redsnow jailbrake on my 2g iphone and everything is perfect including the sim unlock.
  6. magicalan

    magicalan New Member

    Joined:
    Jun 3, 2009
    Messages:
    46
    Likes Received:
    0
    worked for me

    Please Register or Log in to view images

    ipod touch 2g 3.0
  7. DanzP

    DanzP New Member

    Joined:
    May 18, 2009
    Messages:
    137
    Likes Received:
    0
    Device:
    2G iPod touch
    working fine
  8. NeSEncHo

    NeSEncHo Active Member

    Joined:
    Jul 16, 2008
    Messages:
    1,322
    Likes Received:
    0
    It's been perfect. 'cept for Cydia being a pain.
  9. Ltn.R_Ripley

    Ltn.R_Ripley New Member

    Joined:
    Jun 20, 2009
    Messages:
    26
    Likes Received:
    0
    Hi...It worked 4 me 2!! Yikes!

    I´m So effin´happy!! Well...See,I had HUGE probs making Redsnow Go into the whole Rom boot\rom disk thingy,and make my 2G Ipod Touch accept redsnow making THAT,so either it got stuck on the 3rd reboot OR it just finished the whole process in 15sec´s and claimed my pod to be jailbroken,and left it with either a black or a white screen....BUT....

    Then I slept 4 two hours,turned off the comp running Vista,woke up,tried the whole process on my Eee PC901 running Windows 7,but lo and behold-in 7,it just crashed right after u clicked NEXT after u browsed\loaded the firmware into Redsnow.

    So I started up my Vista Desktop,and FINALLY___The 2nd time,after a usual "Black screen of nothingness",I turned off G.Chrome and ALL other applications running and I waited until JUST BEFORE the 3rd reboot before releasing the Home button,AND THEN IT STARTED WORKING THE MAGIC...and now,yepp-u guessed it- I have jailbroken 16GB 2nd Gen Ipod Touch. Gonna do the same thing to my 1st gen iphone if I´m satiesfied with the whole Cydia thingy!
  10. slucas

    slucas New Member

    Joined:
    Jan 5, 2009
    Messages:
    32
    Likes Received:
    0
    Device:
    2G iPod touch
    mine worked but the apps wouldn't install icons or be accessable via seach thing. Only cydia and winterboard worked, 5-row didn't install, and a few others that have been reported as working would not add either. doing a restore then re-jb to see if the problem was bad data left on my pod.

Share This Page