Any jailbreaking suggestions for 3.01 new Iphone?

Discussion in 'iPhone' started by Technostorm, Sep 2, 2009.

  1. Technostorm

    Technostorm New Member

    Joined:
    Nov 21, 2008
    Messages:
    91
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    Having a problem which seems to be minor, but can't seemed to figure out how to JB with the new A400 firmware.

    First of all, I only gotten the new 3GS yesterday. Backed up all the IBEC and IBSS files. Then, had to download the A341 3.0 software since redsn0w0.8 couldn't recognize the newer A400 firmware. Once I opened up redsn0w, I pointed to the A341 firmware and it recognized it but since my Iphone was off, I was trying to follow its direction to manually hold power/home button. As it loads, I'm stuck on "Waiting for reboot" screen in redsn0w, but the phone never boots up. So waited and waited.. /sigh..

    Think Dev+team will have a new version of redsn0w out soon which supports 3.01's A400? Or is there an alternative method?

    Thanks in advance.

    Technostorm
  2. Kayzo

    Kayzo Member

    Joined:
    Apr 22, 2009
    Messages:
    423
    Likes Received:
    0
    Device:
    iPhone 5 (White)
    The 3.0.1 jailbreak is exactly the same as the 3.0 one.
    Choose the 3.0 firmware on redsn0w then follow the on-screen instructions.
    Really easy, just try again.
  3. Technostorm

    Technostorm New Member

    Joined:
    Nov 21, 2008
    Messages:
    91
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    ok, maybe I'm an idiot or maybe mattym mistakenly written wrong the firmware required. In his FAQ, he said iPhone1,2_3.0_7A341_Restore.ipsw, but I think it must be iPhone2,1_3.0_7A341_Restore.ipsw instead. Because I even tried to downgrade restore from Itune to iPhone1,2_3.0_7A341_Restore.ipsw and it mentioned I couldn't be of incompatible.

    I'm suspecting for a 3GS, we used the "iPhone2,1_3.0 instead of the iPhone1,2 right" right?

    Also, do I need to restore thru iTune to 3.0? or should I just keep 3.01 and run redsn0w pointing to the 3.0 ipsw instead?

    Damn! I sound like such a nuub! hehe.
  4. Ulysses_609

    Ulysses_609 Member

    Joined:
    Jan 26, 2008
    Messages:
    246
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    Just stay on 3.0.1 and the ipsw you want to use in redsn0w is the iPhone2,1_3.0 7A341 since you are using a 3GS. And if you get stuck at waiting for reboot just unplug the phone and plug it back in
  5. Technostorm

    Technostorm New Member

    Joined:
    Nov 21, 2008
    Messages:
    91
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    Ok, now managed to Jailbroken but lost my AT&T carrier. I guess this firmware file is foreign. It popped up Chinese, then some Spanish, and on my top left corner of my phone screen, I do not see my carrier nor 3G..

    meh! its so darn hard to find the appropriate firmware.. /sigh.

    Now, restoring back to 3.01 original file.. hopefully I get my carrier back.
    ------------------double post merged------------------
    Ok, re-jailbroke it again using a different downloaded iPhone2,1_3.0_7A341_Restore.ipsw and it worked now. Thanks for the help guys!
  6. SeeFreaky

    SeeFreaky New Member

    Joined:
    Mar 21, 2008
    Messages:
    596
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    Try hitting restore in iTunes, and let iTunes download the firmware, then search for it.
  7. Technostorm

    Technostorm New Member

    Joined:
    Nov 21, 2008
    Messages:
    91
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    Nope, doesn't work that way. Itune will restore to 3.01 and not 3.0. If it were that easy, then I wouldn't be posting asking.
  8. Ulysses_609

    Ulysses_609 Member

    Joined:
    Jan 26, 2008
    Messages:
    246
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    just google it. I would give you the direct link to the firmware but im not sure if I would get banned or something for posting the link. Unless you pm me
  9. Technostorm

    Technostorm New Member

    Joined:
    Nov 21, 2008
    Messages:
    91
    Likes Received:
    0
    Device:
    iPhone 3GS (White)
    Thanks, I've actually gotten the firmware. The first one was trashed with gibberish and didn't work. Then, I tried another one and that was in .zip file. I ended up just changing the .zip to .ipsw and it worked flawlessly.

    As for the previous poster, when you try to restore a 3.01 from Itune, it WILL restore 3.01 if you don't already have it in the computer. It will NOT allow you choose which firmware to download.

    All in all, I've had it working that same day but it did take some time to sort out a clean and working 3.0 ipsw as there are some really crappy people posting and seeding false files.

    Report: I 3GS works great and smooth. The battery is draining a bit faster tho, I suspect its some of the softwares I've installed thru cydia including winterboard themes, etc.

    Thanks again all.
  10. Ulysses_609

    Ulysses_609 Member

    Joined:
    Jan 26, 2008
    Messages:
    246
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    Your welcome

    Please Register or Log in to view images


    And for your battery issue, winterboard might be the cause of that or any other apps from cydia that run in the background

Share This Page