Annoying Cellular popup

Discussion in 'iPhone' started by antonixic, Sep 21, 2010.

  1. antonixic

    antonixic Member

    Joined:
    Jun 30, 2009
    Messages:
    59
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    Hi,
    I want to turn 3G and EDGE off (to save battery life) so I went to Setting > General > Network and turn them off. Everything look ok.
    But everytime when I go to Messages, an annoying popup keep telling me that Turn on Cellular Data to access data (I dont want MMS)
    So, how can I get rid of that annoying popup everytime I go to Messages?
    Thank!
  2. ChrisGonzales90

    ChrisGonzales90 Banned

    Joined:
    Sep 5, 2010
    Messages:
    1,137
    Likes Received:
    0
    Device:
    iPad
    You need 3G or Edge ON in order to view and send messages.
  3. Shukketsu.Azuguad

    Shukketsu.Azuguad Member

    Joined:
    Jun 21, 2009
    Messages:
    596
    Likes Received:
    13
    Device:
    iPhone 5 (Black)
    Only to send MMS, not SMS. I send SMS with 3G and EDGE off all of the time.

    @OP, just click ok or whatever it says. Yes, I know it's annoying [I have it too], or you can take it to AT&T or whatever company you bought it through [if you live outside of the USA], and see if they can fix it.
  4. antonixic

    antonixic Member

    Joined:
    Jun 30, 2009
    Messages:
    59
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    I bought it through Apple store and I live outside USA

    Please Register or Log in to view images

    Customer service over here is really bad, they even dont know what it is when I talk to them on phone, haiz.

    I tried fake APN (still leave edge on but it cant access to cellular data) but another popup tell me that "Cant access cellular data" instead "Turn cellular data on"
    Lolz, popups are really annoying

    Please Register or Log in to view images

    )
  5. germ

    germ New Member

    Joined:
    Dec 25, 2008
    Messages:
    211
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    seriously is all this trouble with the extra 15mins of battery life you are going to get?
  6. Shukketsu.Azuguad

    Shukketsu.Azuguad Member

    Joined:
    Jun 21, 2009
    Messages:
    596
    Likes Received:
    13
    Device:
    iPhone 5 (Black)
    I actually get a second day of usage. [Second day meaning that I'm not forced to charge the device at the end of each day].
  7. Unregistered

    Unregistered Guest

    Solution!!!

    Try to turn off Face Time in Settings/Phone. This worked for me!
  8. picklejw

    picklejw Member

    Joined:
    Oct 20, 2008
    Messages:
    875
    Likes Received:
    0
    Device:
    iPad
    The new 4.2.1 has technology which saves battery life by better managing the cell radios on board your device. I have noticed a big improvment on my iPhone 4. Try updating, its a tethered jailbreak but honestly I dont see what the big issue is with it.

Share This Page