Ad-Hoc Connection, Safari Problem

Discussion in 'iPod touch' started by Stormsys, Jul 26, 2010.

  1. Stormsys

    Stormsys New Member

    Joined:
    Dec 17, 2008
    Messages:
    7
    Likes Received:
    0
    Device:
    2G iPod touch
    Ello guys,

    Right so heres my issue:

    I have a laptop connected to the internet, i then have a wireless card built in which i have setup an AD-HOC connection to the ipod.

    The connection is fine, verifeid by a few tests... ive SSH'ed the ipod, from the ipod ive typed the following:
    (for the record,the ipod is 192.168.2.2 and im 192.168.2.1) ive got apache running on the laptop.

    Code:
    curl -I http://192.168.2.1
    HTTP/1.1 200 OK
    Date: Tue, 27 Jul 2010 00:15:11 GMT
    Server: Apache/2.2.11 (Win32) PHP/5.3.0
    X-Powered-By: PHP/5.3.0
    Content-Type: text/html
    
    now the issue is that safari refuses to connect, it comes up with a black dimmed screenand "connecting Connecting..." in the middle, my question is why is safari not ulitising the connection that exists. Let me just clarify, safari wont try to connect, my firewall decets no efforts of connection i try visit http://192.168.2.1 from safari and its stuck on that screen.

    so basicly what can i do to fix this issue?

    Any help is apriciated, thanks in advnace

    Please Register or Log in to view images

  2. RandomEskimo

    RandomEskimo Active Member

    Joined:
    Apr 27, 2010
    Messages:
    1,198
    Likes Received:
    2
    Device:
    iPad 2 (Black)
    I had that problem using my iFile server. If I used it over the ad-hoc to my pc it would work fine on the pc but on the iPod it would say "connecting". It would work on the home network, with an internet connection. It's just something that happens with ad-hocs I guess.
  3. Stormsys

    Stormsys New Member

    Joined:
    Dec 17, 2008
    Messages:
    7
    Likes Received:
    0
    Device:
    2G iPod touch
    Its Quite frustrating, I had it working over ayear ago(this was like firmware 2.something though), im trying it on 2 diffrent ipods the same story with both.
    ------------------double post merged------------------
    Well forcing it to use a local proxy server has fixed it but it is limited to https, u cannot use socks4. and it semes that u can proxy the mail program:/

Share This Page