About the wifi problem in 2.0 firmware

Discussion in 'iPod touch Firmware 2.X' started by Kenmu, Jul 12, 2008.

  1. Kenmu

    Kenmu New Member

    Joined:
    Jan 8, 2008
    Messages:
    2
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    Well it seems that some people including myself are having problems with the wifi after installing the 2,0 firmware, I have tired everything from reseting my network settings to restoring my ipod, the wifi connects and has good signal but it doesnt seem to be downloading any info from the internet. Before I installed the 2.0 firmware the wifi in my ipod was fine.

    I got tired of the problem so I downgrade from 2.0 back to 1.1.4, but it didnt work, I had the same problem, the wifi connected but no internet, so i downgraded again from 1.1.4 to 1.1.1 and nothing I still have the same problem.

    I have red some posts in the apple forum fom users with the same problem, and some say they fixed the problem upgrading the router firmware but I also did that and nothing.

    Please I need Help I have tried everything and having and ipod touch without wifi is like having a regular ipod video with a cool interfase!!!
  2. Swat

    Swat New Member

    Joined:
    Jun 6, 2008
    Messages:
    105
    Likes Received:
    0
    Device:
    3G iPod touch
    Check if you have your router connected. That was my problem. lol
  3. AndersTheSwede

    AndersTheSwede New Member

    Joined:
    May 23, 2008
    Messages:
    7
    Likes Received:
    0
    I've had similar problems. It will sometimes go through but there is serious latency and hangs.

    I restored the touch (and reset my router) but now the problem has only gotten worse with me no receiving NO bars. I'm sitting 5 feet from the router.

    WTF is going on?
  4. mynameisBEEKMAN

    mynameisBEEKMAN Member

    Joined:
    Nov 3, 2007
    Messages:
    473
    Likes Received:
    3
    Device:
    2G iPod touch
    Make sure you have DNS set up correctlly on your Ipod...?
  5. cbubbagump

    cbubbagump Member

    Joined:
    Dec 20, 2007
    Messages:
    75
    Likes Received:
    0
    Device:
    4G iPod touch
    i also have this wifi problem
  6. Spiderwebb

    Spiderwebb New Member

    Joined:
    Jul 9, 2008
    Messages:
    17
    Likes Received:
    0
  7. Blink

    Blink New Member

    Joined:
    Dec 3, 2007
    Messages:
    35
    Likes Received:
    0
    Device:
    2G iPod touch
    Plug the Ethernet in.

    /sarcasm
  8. essence7

    essence7 New Member

    Joined:
    Jul 12, 2008
    Messages:
    11
    Likes Received:
    0
    I'm still having the same problem but the odd part is that I can pick up on other wifi networks (the ones I tried in the mall) and connect but when it comes to MY linksys router it says I have signal but it doesn't connect that well (if at all) its so frustrating! I'm really hoping apple will address this in 2.1
  9. crizh4x

    crizh4x Active Member

    Joined:
    Sep 19, 2007
    Messages:
    4,474
    Likes Received:
    17
    Device:
    2G iPod touch
    Oddly enough, the WiFi is actually controlled by a chip on the motherboard... iPhone users are usually affected by this. I think Ziphone has an option to fix this too. If you are on 1.1.4, try that out and post back. I have had no issues btw.

    I'm pretty sure that 2.0 actually updates this for the new authentications etc. try it out and see what happens.
  10. newdude

    newdude New Member

    Joined:
    Jul 4, 2008
    Messages:
    119
    Likes Received:
    0
    Device:
    iPod touch
    Im not sure if it has anything to do with it, but i first tried my wifi when i was still connected to my wifi enabled laptop.

    I remember having the same problem in 1.1.4 and youtube wouldn't work. I did that, made sure youtube is working then I disconnected my Ipod from my laptop. No more problems since.

Share This Page