A newbie who wants to upgrade and/or jailbreak

Discussion in 'iPod touch Firmware 3.0' started by InterFan, Oct 8, 2009.

  1. InterFan

    InterFan New Member

    Joined:
    Oct 8, 2009
    Messages:
    14
    Likes Received:
    0
    Device:
    2G iPod touch
    Hi folks,

    Reading the material made me feel like in a jungle. I don't know where to start.

    I've bought iPodTouch 2G and it has 2.2.1 version.

    I want to jailbreak and I also prefer the newest version.

    As I understand the newest iPhone OS in iTunes is 3.1.2 which is yet to be jailbroken.

    So what should I do first? is there a way for me to have a new jailbroken version(ie 3.0 or 3.1)?

    I have a newly-bought MacBook Pro if it's needed.

    Please help me.
  2. canesfan

    canesfan Member

    Joined:
    Apr 12, 2009
    Messages:
    969
    Likes Received:
    1
    Device:
    iPhone 4S (Black)
    interfan,
    willing to help u with all this. I too have an ipod touch 2g but on OS 3.0. If you want to upgrade/jailbreak i reccomend 3.1.1 versus 2.2.1 because all and all it is an easier jailbreak. If you have a mac, on 3.1.1 to jailbreak you wpuld need to upgrade to 3.1.1 which costs 10 bucks on itunes i believe. I believe you can use the newest version of pwnagetool from the dev-team to jailbreak. Here is the link to the post. http://blog.iphone-dev.org/post/202796266/all-aboard-the-update-train . read the post and then download the file. in Pwnagetool you will be creating a custom firmware to restore to in itunes. search youtube for a toutorial about this.
  3. InterFan

    InterFan New Member

    Joined:
    Oct 8, 2009
    Messages:
    14
    Likes Received:
    0
    Device:
    2G iPod touch
    Thanks for trying to help.
    It'll probably last for several levels overall.

    I have a few questions:
    1. Are you talking about this upgrade - http://www.apple.com/ipodtouch/software-update.html? It costs $4.95. I'm afraid to press on the update button in iTunes as I don't know whether it will show me the price before starting to update. I also don't understand why I see there 3.1.1 version rather than the reported(in some forums/blogs) 3.1.2 which they is we must not update to if we care about jailbreaking?
    2. Using the link you provided, I see 2 things which look kind of contradicting.
    and this -
  4. canesfan

    canesfan Member

    Joined:
    Apr 12, 2009
    Messages:
    969
    Likes Received:
    1
    Device:
    iPhone 4S (Black)
    1.i know that an ipod touch 2g jailbreak is not supported at 3.1.2 but i dont know how to upgrade to an official firmware file that is not the latest available.
    2. its saying it works if ur ipod was pwned at 3.0 or 3.0.1. my only advice right now is to wait for Geohot's jailbreak, blackra1n. It supposedly jailbreaks all devices and the new 3.1.2 firmware. just keep an eye out on the dev-teams website, blog.iphone-dev.org.
  5. InterFan

    InterFan New Member

    Joined:
    Oct 8, 2009
    Messages:
    14
    Likes Received:
    0
    Device:
    2G iPod touch
    Yeah, your advice is what I'm going to do even though I thought that PwnageTool is the one who is going to be used to jailbreak 3.1.2 version.
  6. ninobehar

    ninobehar New Member

    Joined:
    Oct 7, 2009
    Messages:
    17
    Likes Received:
    0
    Hello!

    I have a similar problem in home. My sister owns a Ipod Touch 2g version 2.2.1 and she wants me to jailbreak it for her.
    I never jailbroken an Ipod, and I have no idea what to do and how to start. What should I do? Can anyone help me?

    Thank you,

    Nino
  7. InterFan

    InterFan New Member

    Joined:
    Oct 8, 2009
    Messages:
    14
    Likes Received:
    0
    Device:
    2G iPod touch
    Do you want to break your current 2.2.1 version, or to break an updated version?
  8. ninobehar

    ninobehar New Member

    Joined:
    Oct 7, 2009
    Messages:
    17
    Likes Received:
    0
    What is the best way? The 2.2.1 jailbreak or the most recent version? I realy dont know.
  9. InterFan

    InterFan New Member

    Joined:
    Oct 8, 2009
    Messages:
    14
    Likes Received:
    0
    Device:
    2G iPod touch
    The most recent version, 3.1.2, is unjailbreakable currently. It's widely suggested to wait for a jailbreak to come out soon enough.
  10. KerrWasHere

    KerrWasHere Active Member

    Joined:
    Apr 19, 2009
    Messages:
    1,493
    Likes Received:
    13
    Device:
    iPhone 5 (Black)
    I recomend that newbs do not jailbreak their iPods untill they, know how to use them normally

    then after a couple of weeks, jailbreak and use minor packages and learn what those do, then get a form of ssh, and learn the locations of important folders and what not to edit, then try packages that you have to use ssh to use

Share This Page