A fix for libusb problems in Vista.

Discussion in 'iPod touch 2G Jailbreak: redsn0w, 24kpwn, etc.' started by Supertod, Feb 25, 2009.

  1. Supertod

    Supertod Member

    Joined:
    Feb 8, 2009
    Messages:
    290
    Likes Received:
    0
    Device:
    2G iPod touch
    Hey guys, if your having problems with libusb in vista and you use an auto-booting tool for your iPod Touch 2g (like DHowett's decovery) then I made a solution which enables libusb only when you need it. Just copy this text into a .txt file, rename it to a .bat file, then place it where you like

    Please Register or Log in to view images



    Code:
    @echo off
    
    echo "Enabling LibUSB"
    cd C:\Program Files\LibUSB-Win32\bin
    install-filter.exe -i
    
    cd C:\Users\*NAME HERE*\*BOOT TOOL LOCATION*\
    
    echo: "Disabling LibUSB"
    cd C:\Program Files\LibUSB-Win32\bin
    install-filter.exe -u 
    
    echo "DONE"
    

    Please tell me if this works as I am very new to this type of coding

    Please Register or Log in to view images

  2. Veritas06

    Veritas06 New Member

    Joined:
    Dec 23, 2007
    Messages:
    468
    Likes Received:
    0
    Device:
    2G iPod touch
    I had a little problem in the beginning getting it to load Decovery correctly, but after a few tweaks, i got it working:

    I'll try to remove the "Pause >nul" now that i got Decovery to load up.
    EDIT: Removed the pauses so it loads up just fine now =]

    Thanks for the post =]. I don't know why i didn't think of this. Instead i had a bat that would turn LibUSB on/off, & but had to load my boot tool separately.

    ~Thanks!
  3. Supertod

    Supertod Member

    Joined:
    Feb 8, 2009
    Messages:
    290
    Likes Received:
    0
    Device:
    2G iPod touch
    Glad it worked, I only made this for my personal use, but I thought it would be good to share it with other people

    Please Register or Log in to view images

Share This Page