4.0 Required?

Discussion in 'iTunes App Store Games & Apps' started by thedj, Jul 18, 2010.

  1. thedj

    thedj Member

    Joined:
    Nov 29, 2009
    Messages:
    913
    Likes Received:
    8
    Device:
    iPhone 4S (Black)
    I tried to download an app from the app store and it says firmware 4.0 is required to download it. Is there a way to trick the app store in to thinking you have 4.0, but still make it say 3.1.2 in the settings?
  2. NitroBum

    NitroBum Active Member

    Joined:
    Feb 23, 2009
    Messages:
    1,549
    Likes Received:
    12
    Device:
    iPhone 4S (Black)
    You might not want to use an app that requires 4.0 on a pre-4.0 firmware. It might actually be true you know? But yeah, I'm pretty sure there are 4.0 spoofers.
  3. Lux2GS

    Lux2GS Well-Known Member

    Joined:
    Jul 1, 2010
    Messages:
    3,678
    Likes Received:
    138
    Device:
    iPhone 4S (Black)
    /System/Library/CoreServices/Springboard.app

    Systemversion.plist - Edit it, and have fun.
  4. GazaIan

    GazaIan Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    5,975
    Likes Received:
    431
    Device:
    Nexus 4
    According to your account info, you have a 3GS on a jailbroken 3.1.2.... you do release that you can install and jailbreak 4.0, right? Just do that and apps will be less of a pain.
  5. Bubalooshi

    Bubalooshi Active Member

    Joined:
    May 22, 2008
    Messages:
    2,432
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    I recommend backing up SHSH's and following a tutorial on updating.

    You can remain jailbroken and not have to deal with any iOS 4 exclusive errors.
  6. GazaIan

    GazaIan Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    5,975
    Likes Received:
    431
    Device:
    Nexus 4
    Agreed..
  7. Fike

    Fike Member

    Joined:
    Mar 24, 2010
    Messages:
    543
    Likes Received:
    0
    Device:
    3G iPod touch
    ...only problem is Apple stops signing past firmwares so he can't back up the shsh blobs.
  8. thedj

    thedj Member

    Joined:
    Nov 29, 2009
    Messages:
    913
    Likes Received:
    8
    Device:
    iPhone 4S (Black)
    Firstly, I dont have my SHSH's for 3.1.2,

    Secondly, I cant upgrade to 4.0 because it does not hacktivate and I depend on the unlock.

    Thirdly, Most of the cydia mods that I use are not compatible with 4.0, such as iBlueNova, so I would prefer to stay on my 3.1.2 tethered jailbreak for now.
  9. ripply

    ripply Active Member

    Joined:
    Jul 31, 2009
    Messages:
    1,159
    Likes Received:
    2
    Device:
    iPhone 4 (Black)
    There is a FW Spoofer package in cydia which trick the AppSore to think you are on the specif FW. I don't know if they made one for 4.0 yet.
  10. bobby681

    bobby681 Active Member

    Joined:
    Jun 24, 2008
    Messages:
    2,588
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    If an app says it needs 4.0, it more than likely needs an API that was only made available in the 4.0 sdk (remember all those fancy new ones mr jobs was on about?

    Please Register or Log in to view images

    ) If you did spoof your device to show 4.0, there is always a chance it just wouldn't work anyway.

Share This Page