4.0 not compatible?

Discussion in 'iOS Jailbreak & Cydia' started by jmwerkus, Feb 14, 2010.

  1. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S
    I'm "4.0" (systemversion.plist) and some apps say I can't install cuz I'm not on 3.0... Why don't they just check if ur not on 2.0, instead of making sure ur on 3.0
  2. Shawa

    Shawa Super Moderator

    Joined:
    Jan 31, 2009
    Messages:
    3,188
    Likes Received:
    22
    Device:
    Nexus 4
    Because the system version detection detects what you're on, not what you are not.

    What possible reason (other than "Gaiz, I'm on 4.O") would have for spoofing your version number?
  3. TakenAppleDownAPeg

    TakenAppleDownAPeg Member

    Joined:
    Oct 6, 2009
    Messages:
    871
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    Because 1 apple didn't build there system to work with all the jailbreaks we implement and 2 its a lot more efficient, code wise to just do a single check to see if your on 3.0 than checking for 1.x and 2.x
  4. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S
    I put it on 4.0 cuz I dunno
  5. Shawa

    Shawa Super Moderator

    Joined:
    Jan 31, 2009
    Messages:
    3,188
    Likes Received:
    22
    Device:
    Nexus 4
    Then change it back?

Share This Page